Bug 20350 - Add column configuration to table of saved reports
Summary: Add column configuration to table of saved reports
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 20814
  Show dependency treegraph
 
Reported: 2018-03-07 13:20 UTC by Owen Leonard
Modified: 2018-07-18 12:14 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20350: Add column configuration to table of saved reports (5.06 KB, patch)
2018-03-07 15:49 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 20350: Add column configuration to table of saved reports (5.11 KB, patch)
2018-03-12 11:15 UTC, Jesse Maseto
Details | Diff | Splinter Review
Bug 20350: Add column configuration to table of saved reports (5.14 KB, patch)
2018-04-04 14:24 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 20350: Add column configuration to table of saved reports (5.20 KB, patch)
2018-04-05 06:01 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2018-03-07 13:20:48 UTC
It should be possible to configure the display of columns in the saved reports table using the Colvis plugin.
Comment 1 Owen Leonard 2018-03-07 15:49:24 UTC Comment hidden (obsolete)
Comment 2 Axelle Aix-Marseille Université 2018-03-12 10:51:14 UTC
Tested on sandbox Biblibre n°1

Go to Reports -> Use saved.
there is not a "Column visibility" button in the table's pagination toolbar and the report groups are not correctly displayed in tabs

Go to Administration -> Columns settings.
- Find "id=table_reports." : OK
- Make some selections to configure default settings of the reports table : OK. We selected json_url and saved_results.
- these defaults were not applied.
Comment 3 Jesse Maseto 2018-03-12 11:15:24 UTC Comment hidden (obsolete)
Comment 4 Lucie Gay 2018-03-13 14:19:13 UTC
Tested on sandbox Biblibre n°9

Go to Reports -> Use saved : 
there is no button "Column visibility" in the table's pagination toolbar, report groups are displayed like a list and not in tabs

Go to Administration -> Columns settings :
The selection is not applied
Comment 5 Owen Leonard 2018-04-04 14:24:01 UTC
Created attachment 73642 [details] [review]
Bug 20350: Add column configuration to table of saved reports

This patch makes changes to the saved reports template to enable a
columns configuration button. Settings for the table have been added to
columns_settings.yml.

To test, apply the patch and go to Reports -> Use saved.

 - Confirm that there is a "Column visibility" button in the
   table's pagination toolbar.
 - Confirm that showing and hiding columns via the button is working
   correctly.
 - Confirm that the first, second, and last columns cannot be toggled.

Go to Administration -> Columns settings.

- Expand the "Reports" section.
- Find "id=table_reports."
- Make some selections to configure default settings of the reports
  table.
- Return to reports and confirm that these defaults are applied.

Signed-off-by: Jesse Maseto <jesse@bywatersolutions.com>
Comment 6 Owen Leonard 2018-04-04 14:25:43 UTC
I have rebased the patch and would like to ask QA to look at it. I can't reproduce the errors reported in Comment 4, and I think it may have been a browser cache problem.
Comment 7 Katrin Fischer 2018-04-05 06:01:34 UTC
Created attachment 73673 [details] [review]
Bug 20350: Add column configuration to table of saved reports

This patch makes changes to the saved reports template to enable a
columns configuration button. Settings for the table have been added to
columns_settings.yml.

To test, apply the patch and go to Reports -> Use saved.

 - Confirm that there is a "Column visibility" button in the
   table's pagination toolbar.
 - Confirm that showing and hiding columns via the button is working
   correctly.
 - Confirm that the first, second, and last columns cannot be toggled.

Go to Administration -> Columns settings.

- Expand the "Reports" section.
- Find "id=table_reports."
- Make some selections to configure default settings of the reports
  table.
- Return to reports and confirm that these defaults are applied.

Signed-off-by: Jesse Maseto <jesse@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2018-04-05 06:02:11 UTC
Works nicely for me, maybe a cache/Plack problem with c#4.
Comment 9 Jonathan Druart 2018-04-05 17:15:36 UTC
I have moved this change to its own bug, bug 20530:
-          columnname: collection:
+          columnname: collection

To ease backport
Comment 10 Jonathan Druart 2018-04-05 17:54:52 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 11 Jonathan Druart 2018-05-24 18:22:20 UTC
(In reply to Lucie Gay from comment #4)
> Tested on sandbox Biblibre n°9
> 
> Go to Reports -> Use saved : 
> there is no button "Column visibility" in the table's pagination toolbar,
> report groups are displayed like a list and not in tabs
> 
> Go to Administration -> Columns settings :
> The selection is not applied

It was a real bug :)
See bug 20814.