Bug 2046 - Suggestions: Title Field too small
Summary: Suggestions: Title Field too small
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P3 normal (vote)
Target Milestone: ---
Assignee: Kristina Hoeppner
QA Contact:
URL:
Whiteboard:
Keywords:
: 10989 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-24 10:16 UTC by Nicole C. Engard
Modified: 2014-03-16 12:29 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
placing suggestion - long title (30.88 KB, image/png)
2008-07-18 05:20 UTC, Chris Cormack
Details
suggested - title cut (16.65 KB, image/png)
2008-07-18 05:20 UTC, Chris Cormack
Details
proposed patch (4.84 KB, patch)
2013-04-26 04:31 UTC, Kristina Hoeppner
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 2046 - Suggestions: Title Field too small (4.90 KB, patch)
2013-04-26 15:16 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 2046 - Suggestions: Title Field too small (5.16 KB, patch)
2013-04-27 10:37 UTC, Katrin Fischer
Details | Diff | Splinter Review
screenshot (25.41 KB, image/png)
2013-04-27 10:38 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:37:34 UTC


---- Reported by nengard@gmail.com 2008-04-24 10:16:34 ----

<nengard> For managing suggestions - looks like there is a character limit on the title field - this may not be a problem, but i entered a title that got chopped off
 <owen> nengard: The field in the database is limited to 80 characters, which I agree isn't big enough. 

Can we up this to 255?  I have submitted a few titles that are real titles but have been truncated.

This is on this page: koha/opac-suggestions.pl?op=add



---- Additional Comments From nengard@gmail.com 2008-07-18 05:19:45 ----

This is still an issue.  see attachments



---- Additional Comments From nengard@gmail.com 2008-07-18 05:20:12 ----

Created an attachment
placing suggestion - long title





---- Additional Comments From nengard@gmail.com 2008-07-18 05:20:37 ----

Created an attachment
suggested - title cut





---- Additional Comments From koha@brinkerhoff.org 2008-12-23 17:27:59 ----

diff --git a/installer/data/mysql/kohastructure.sql b/installer/data/mysql/kohastructure.sql
index fe924e6..595def6 100644
--- a/installer/data/mysql/kohastructure.sql
+++ b/installer/data/mysql/kohastructure.sql
@@ -1915,7 +1915,7 @@ CREATE TABLE `suggestions` (
   `STATUS` varchar(10) NOT NULL default '',
   `note` mediumtext,
   `author` varchar(80) default NULL,
-  `title` varchar(80) default NULL,
+  `title` varchar(255) default NULL,
   `copyrightdate` smallint(6) default NULL,
   `publishercode` varchar(255) default NULL,
   `date` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,

This allows for title lengths up to 255 characters.



---- Additional Comments From nengard@gmail.com 2009-01-02 12:33:24 ----

Does this mean that it's fixed? Or that we need to find out why the code is chopping the title off?



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:37 UTC  ---

This bug was previously known as _bug_ 2046 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2046
Imported an attachment (id=463)
Imported an attachment (id=464)

Actual time not defined. Setting to 0.0
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, chris@bigballofwax.co.nz.
   Previous assignee was rch@liblime.com.
CC member bchurch@ptfs.com does not have an account here
CC member rch@liblime.com does not have an account here
The original submitter of attachment 463 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 464 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Nicole C. Engard 2012-10-15 19:51:51 UTC
At some point this field was changed back to only 80 characters ... and the text field in the OPAC is limited to only 50 cgi-bin/koha/opac-suggestions.pl?op=add

Titles can be very long ... and this 50/80 character limit is too small.

Nicole
Comment 2 Owen Leonard 2013-03-25 15:47:04 UTC
This bug is still valid in master as of 3.12 beta1
Comment 3 Kristina Hoeppner 2013-04-02 00:55:42 UTC
This needs a DB upgrade. Will do that with Chris' help later this week.
Comment 4 Katrin Fischer 2013-04-02 10:00:50 UTC
Yay! :)
Comment 5 Kristina Hoeppner 2013-04-26 04:31:33 UTC Comment hidden (obsolete)
Comment 6 Owen Leonard 2013-04-26 15:16:05 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-04-27 10:37:06 UTC
Created attachment 17747 [details] [review]
[PASSED QA] Bug 2046 - Suggestions: Title Field too small

Increase both on staff and OPAC interface
from 80 to 255 characters to be saved in
the database. Shown will be 80 characters.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Clean patch, workes as described.

To test:
- Apply patch and run database update
- Check that the column in the database is now varchar(255)
- Enter a new suggestion in the OPAC
- Edit this suggestion in staff
- Confirm form has the new max value set
Comment 8 Katrin Fischer 2013-04-27 10:38:08 UTC
Created attachment 17748 [details]
screenshot

Maybe it would be a bit more visually appealing if we kept the size at 50 but increased the maxsize to new increased value?
Comment 9 Jared Camins-Esakov 2013-04-27 12:12:56 UTC
This patch has been pushed to master and 3.12.x.
Comment 10 Chris Cormack 2013-04-27 22:21:41 UTC
Pushed to 3.10.x will be in 3.10.6
Comment 11 Katrin Fischer 2014-03-16 12:29:13 UTC
*** Bug 10989 has been marked as a duplicate of this bug. ***