Bug 20546 - Shelving location not displayed on checkin
Summary: Shelving location not displayed on checkin
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Magnus Enger
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 18276
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-09 10:37 UTC by Magnus Enger
Modified: 2018-06-11 06:56 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20546: Display shelving location on checkin (1.32 KB, patch)
2018-04-09 10:42 UTC, Magnus Enger
Details | Diff | Splinter Review
Bug 20546: Display shelving location on checkin (1.37 KB, patch)
2018-04-10 05:27 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20546: Display shelving location on checkin (1.44 KB, patch)
2018-04-30 09:42 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2018-04-09 10:37:42 UTC
To reproduce:

- Make sure you have a couple of books with a value for shelving location (952$c)
- Check the books out
- Check the books in
- Verify nothing is displayed in the "Shelving location" column on /cgi-bin/koha/circ/returns.pl

Patch coming in a second.
Comment 1 Magnus Enger 2018-04-09 10:42:27 UTC
Created attachment 73850 [details] [review]
Bug 20546: Display shelving location on checkin

Currently, the sehlving location is not being displayed in the table
of checked in items on <intranet>/cgi-bin/koha/circ/returns.pl

To test:
- Make sure you have a couple of books with a value for shelving location (952$c)
- Check the books out
- Check the books in
- Verify nothing is displayed in the "Shelving location" column
- Apply this patch
- Check the books out and in again
- Verify the shelving location is now being displayed
Comment 2 Katrin Fischer 2018-04-10 05:27:17 UTC
Created attachment 73900 [details] [review]
Bug 20546: Display shelving location on checkin

Currently, the sehlving location is not being displayed in the table
of checked in items on <intranet>/cgi-bin/koha/circ/returns.pl

To test:
- Make sure you have a couple of books with a value for shelving location (952$c)
- Check the books out
- Check the books in
- Verify nothing is displayed in the "Shelving location" column
- Apply this patch
- Check the books out and in again
- Verify the shelving location is now being displayed

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 3 Jonathan Druart 2018-04-10 14:37:55 UTC
Caused by 
  commit 6eade474ed3a84a5ba372a26ac27bf9fb4bd2299
  Bug 18276: Remove GetBiblioFromItemNumber - Easy ones
Comment 4 Julian Maurice 2018-04-30 09:42:03 UTC
Created attachment 74934 [details] [review]
Bug 20546: Display shelving location on checkin

Currently, the sehlving location is not being displayed in the table
of checked in items on <intranet>/cgi-bin/koha/circ/returns.pl

To test:
- Make sure you have a couple of books with a value for shelving location (952$c)
- Check the books out
- Check the books in
- Verify nothing is displayed in the "Shelving location" column
- Apply this patch
- Check the books out and in again
- Verify the shelving location is now being displayed

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 5 Jonathan Druart 2018-05-03 16:41:23 UTC
Pushed to master for 18.05, thanks to everybody involved!
Comment 6 Fridolin SOMERS 2018-06-11 06:55:58 UTC
Pushed to 17.11.x for 17.11.07
Comment 7 Fridolin SOMERS 2018-06-11 06:56:27 UTC
Depends on Bug 18276 not in 17.05.x