Bug 20610 - Add BULAC to about page
Summary: Add BULAC to about page
Status: RESOLVED DUPLICATE of bug 20720
Alias: None
Product: Koha
Classification: Unclassified
Component: About (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: claire.hernandez@biblibre.com
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-18 14:13 UTC by claire.hernandez@biblibre.com
Modified: 2018-10-29 08:22 UTC (History)
5 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: String patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 20610: Adds a library (1.34 KB, patch)
2018-04-18 14:15 UTC, claire.hernandez@biblibre.com
Details | Diff | Splinter Review
Bug 20610: Adds a library (1.48 KB, patch)
2018-04-18 19:26 UTC, Séverine Queune
Details | Diff | Splinter Review
Bug 20610: Adds a library (1.54 KB, patch)
2018-04-20 13:04 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description claire.hernandez@biblibre.com 2018-04-18 14:13:32 UTC

    
Comment 1 claire.hernandez@biblibre.com 2018-04-18 14:15:38 UTC
Created attachment 74435 [details] [review]
Bug 20610: Adds a library

Test plan:
1) Apply bug patch
2) Go to staff interface > About page > Koha Team
3) See a new entry "BULAC"
Comment 2 Séverine Queune 2018-04-18 19:26:38 UTC
Created attachment 74503 [details] [review]
Bug 20610: Adds a library

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>
Comment 3 Séverine Queune 2018-04-18 19:28:01 UTC
(In reply to claire.hernandez@biblibre.com from comment #1)
> Created attachment 74435 [details] [review] [review]
> Bug 20610: Adds a library
> 
> Test plan:
> 1) Apply bug patch
> 2) Go to staff interface > About page > Koha Team
> 3) See a new entry "BULAC"
Nice one Claire :)
Thanks !
Comment 4 Nick Clemens 2018-04-20 13:04:20 UTC
Created attachment 74638 [details] [review]
Bug 20610: Adds a library

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Nick Clemens 2018-04-20 13:04:48 UTC
This should probably be moved to bug 7143 (tracking changes to the about page)
Comment 6 Jonathan Druart 2018-04-20 15:08:23 UTC
I do not want to be the bad guy, just a question: what is the requirement for the "special thanks" section?

I have no idea where does come from this list, the last addition was in 2012.
Comment 7 Katrin Fischer 2018-04-21 08:06:40 UTC
I think if a library wants to be listed, we should do it and BULAC for sure deserves it, also sponsoring new features in serials and acq I tink? The list helps to show that libraries are actively involved in Koha's development, they ultimately drive what we do. I was only wondering because Elasticsearch has been funded by a lot of people if we should sightly reword it.

We could make it a habit to add the libraries that used the "Sponsored-by" line to the about page.
Comment 8 claire.hernandez@biblibre.com 2018-05-17 07:57:02 UTC
I think we should thanks more our libraries in patches probably. I thought I could do larger than just BULAC, but it was a first step I needed just at the moment. I could add "Sponsored-by" more in every patches too. It seems it is not in our habits (and it should). Tell me what is the best way to do it in a community way and I can do it.

@cait: "We could make it a habit to add the libraries that used the "Sponsored-by" line to the about page." you talk about the commit message or I miss something ?
Comment 9 Katrin Fischer 2018-08-08 18:13:07 UTC
Hi Claire, sorry to be late here! Catching up never seems to end...

A little info on the Sponsored-by line to go into the commit message is here:
https://wiki.koha-community.org/wiki/Commit_messages#Sponsor_line

I've added the topic of adding the sponsored-by libraries to the about page (semi)automatically to the agenda of the next general IRC meeting:
https://wiki.koha-community.org/wiki/General_IRC_meeting_5_September_2018#Agenda

Hope this will help move things forward :)
Comment 10 Martin Renvoize 2018-10-19 16:22:34 UTC
I've added a patch to bug 20720 to try and bring us a bit more up to date as a whole.. I'll work on a script to try and automate the extraction of 'Sponsored-by' lines from git commit messages as a followup.
Comment 11 Katrin Fischer 2018-10-28 11:40:05 UTC
Bug 20720 adds it now :)

*** This bug has been marked as a duplicate of bug 20720 ***
Comment 12 claire.hernandez@biblibre.com 2018-10-29 08:22:03 UTC
Great, good job, thanks !