Bug 20792 - Can't go to patron record with TranslateNotices active
Summary: Can't go to patron record with TranslateNotices active
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 18789
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-19 23:24 UTC by Katrin Fischer
Modified: 2018-06-27 15:41 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20792: (bug 18789 follow-up) Fix patron edit page if TranslateNotices is set (1.07 KB, patch)
2018-05-21 13:42 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 20792: (bug 18789 follow-up) Fix patron edit page if TranslateNotices is set (1.12 KB, patch)
2018-05-21 13:55 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2018-05-19 23:24:03 UTC
Hope this only happens for me, but if not, this has blocker potential:

To test:
- Activate TranslateNotices
- Go to any patron record
- Internal server errror

From Plack logs:

Template process failed: undef error - The method translated_language is not covered by tests! at /home/vagrant/kohaclone/C4/Templates.pm line 122.
Comment 1 Jonathan Druart 2018-05-21 13:38:49 UTC
Confirmed, caused by
  commit 0ab22e1c7c6b6e8d14a4fb7478ab2a3d42da347d
  Bug 18789: Send Koha::Patron object to the templates
Comment 2 Jonathan Druart 2018-05-21 13:42:23 UTC
Created attachment 75459 [details] [review]
Bug 20792: (bug 18789 follow-up) Fix patron edit page if TranslateNotices is set

translated_language is not a Koha::Patron's method but a simple variable
sent to the template.
Comment 3 Katrin Fischer 2018-05-21 13:55:07 UTC
Created attachment 75460 [details] [review]
Bug 20792: (bug 18789 follow-up) Fix patron edit page if TranslateNotices is set

translated_language is not a Koha::Patron's method but a simple variable
sent to the template.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Katrin Fischer 2018-05-21 13:56:42 UTC
Trivial obvious fix, skipping QA.
Comment 5 Jonathan Druart 2018-05-21 14:04:01 UTC
Thank Katrin!

Pushed to master for 18.05