Bug 20822 - Can't find HOLD_SLIP template when printing
Summary: Can't find HOLD_SLIP template when printing
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 18789
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-25 14:29 UTC by Stefan Berndtsson
Modified: 2019-10-14 19:56 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 20822: (bug 18789 follow-up) Fix HOLD_SLIP (2.04 KB, patch)
2018-05-28 18:13 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 20822: (bug 18789 follow-up) Fix HOLD_SLIP (2.08 KB, patch)
2018-05-28 20:23 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20822: (bug 18789 follow-up) Fix HOLD_SLIP (2.15 KB, patch)
2018-05-28 20:46 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Berndtsson 2018-05-25 14:29:10 UTC
Printing HOLD_SLIP from the Hold found modal can't find the template.

In "returns.tt" the print action is sent "patron.borrowernumber", but the print-slip template parameters in "returns.pl" only include "borrowernumber" and "biblionumber", not "patron".
Comment 1 Jonathan Druart 2018-05-28 18:11:06 UTC
Caused by
  commit ab47e46ea0ade643b308a8b00708d57995c57050
  Bug 18789: Pass a Koha::Patron object from returns.pl
Comment 2 Jonathan Druart 2018-05-28 18:13:06 UTC
Created attachment 75598 [details] [review]
Bug 20822: (bug 18789 follow-up) Fix HOLD_SLIP

Caused by
  commit ab47e46ea0ade643b308a8b00708d57995c57050
  Bug 18789: Pass a Koha::Patron object from returns.pl

circ/returns.pl does not send a $patron Koha::Patron object to the
template in case print_slip is set

Test plan:
Confirm a hold and print the slip
Comment 3 Katrin Fischer 2018-05-28 20:14:54 UTC
Test plan:
- Place a hold on an item or record
- Return an item to fill the hold
- Check the item in
- Pick "print and confirm"
- Instead of the notice, an error will display in the preview pop-up
Comment 4 Katrin Fischer 2018-05-28 20:23:21 UTC
Created attachment 75610 [details] [review]
Bug 20822: (bug 18789 follow-up) Fix HOLD_SLIP

Caused by
  commit ab47e46ea0ade643b308a8b00708d57995c57050
  Bug 18789: Pass a Koha::Patron object from returns.pl

circ/returns.pl does not send a $patron Koha::Patron object to the
template in case print_slip is set

Test plan:
Confirm a hold and print the slip

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Chris Cormack 2018-05-28 20:46:46 UTC
Created attachment 75612 [details] [review]
Bug 20822: (bug 18789 follow-up) Fix HOLD_SLIP

Caused by
  commit ab47e46ea0ade643b308a8b00708d57995c57050
  Bug 18789: Pass a Koha::Patron object from returns.pl

circ/returns.pl does not send a $patron Koha::Patron object to the
template in case print_slip is set

Test plan:
Confirm a hold and print the slip

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 6 Nick Clemens 2018-05-29 14:49:28 UTC
Pushed to master for 18.11.

Awesome work all, thank you.
Comment 7 Martin Renvoize 2018-06-05 09:48:16 UTC
This patch has been pushed to 18.05.x, will be in 18.05.01
Comment 8 Fridolin SOMERS 2018-06-06 10:01:21 UTC
Depends on Bug 18789 not in 17.11.x