Bug 20828 - Step 4 of moremember is used for Housebound and additional attributes
Summary: Step 4 of moremember is used for Housebound and additional attributes
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 5670 21085
Blocks: 21209
  Show dependency treegraph
 
Reported: 2018-05-28 20:41 UTC by Jonathan Druart
Modified: 2018-09-21 12:17 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20828: Step 4 of moremember is used for Housebound and additional attributes (4.79 KB, patch)
2018-07-19 15:41 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 20828: Step 4 of moremember is used for Housebound and additional attributes (4.84 KB, patch)
2018-08-03 10:41 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 20828: Step 4 of moremember is used for Housebound and additional attributes (4.93 KB, patch)
2018-08-03 18:20 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2018-05-28 20:41:47 UTC
Enable the Housebound module and Additional attributes, hit 
cgi-bin/koha/members/memberentry.pl?op=modify&borrowernumber=51&step=4

You see: https://screenshots.firefox.com/kckI5solTzmkbPv4/pro.kohadev.org
Comment 1 Jonathan Druart 2018-05-30 15:25:48 UTC
Not a bug?

  commit 20c2ea7d3a6e24dd13cf3e6dd47108984852607d
  Bug 5670: [Followup] Add 'step 4' edit button.
Comment 2 Katrin Fischer 2018-07-15 18:04:05 UTC
Is the bug that there are 2 Edit links for both that lead to the same page?
Comment 3 Jonathan Druart 2018-07-16 13:19:01 UTC
(In reply to Katrin Fischer from comment #2)
> Is the bug that there are 2 Edit links for both that lead to the same page?

step 4 is used for both housebound module and additional attributes.
Comment 4 Owen Leonard 2018-07-19 15:41:33 UTC Comment hidden (obsolete)
Comment 5 sandboxes@biblibre.com 2018-08-03 10:41:13 UTC
Patch tested with a sandbox, by Cab Vinton <bibliwho@gmail.com>
Comment 6 sandboxes@biblibre.com 2018-08-03 10:41:37 UTC
Created attachment 77466 [details] [review]
Bug 20828: Step 4 of moremember is used for Housebound and additional attributes

This patch modifies the patron edit process so that "Housebound roles"
can be edited as a separate step.

To test, apply the patch and open an existing patron's detail page
(moremember.tt). Test the "edit" links for 'Housebound roles' and
'Additional attributes and identifiers' and confirm that each opens its
own edit page, and saving changes works correctly.

Signed-off-by: Cab Vinton <bibliwho@gmail.com>
Comment 7 Jonathan Druart 2018-08-03 18:20:10 UTC
Created attachment 77483 [details] [review]
Bug 20828: Step 4 of moremember is used for Housebound and additional attributes

This patch modifies the patron edit process so that "Housebound roles"
can be edited as a separate step.

To test, apply the patch and open an existing patron's detail page
(moremember.tt). Test the "edit" links for 'Housebound roles' and
'Additional attributes and identifiers' and confirm that each opens its
own edit page, and saving changes works correctly.

Signed-off-by: Cab Vinton <bibliwho@gmail.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Nick Clemens 2018-08-09 12:25:17 UTC
Awesome work all!

Pushed to master for 18.11
Comment 9 Martin Renvoize 2018-08-10 08:10:24 UTC
Pushed to 18.05.x for 18.05.03. We don't appear to actually have any direct dependency on bug 21085 here so it works well.
Comment 10 Fridolin SOMERS 2018-09-21 12:17:36 UTC
Depends on Bug 21085 not in 17.11.x