Bug 20949 - Koha depends on Clone
Summary: Koha depends on Clone
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Mirko Tietgen
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 18850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-15 10:04 UTC by Mirko Tietgen
Modified: 2018-07-30 12:28 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 20949: Koha depends on Clone (897 bytes, patch)
2018-06-15 10:37 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 20949: Followup: debian/control (955 bytes, patch)
2018-06-15 10:37 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 20949: Koha depends on Clone (894 bytes, patch)
2018-07-03 08:26 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 20949: Followup: debian/control (955 bytes, patch)
2018-07-03 08:26 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 20949: Koha depends on Clone (952 bytes, patch)
2018-07-08 16:47 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20949: Followup: debian/control (1013 bytes, patch)
2018-07-08 16:47 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 20949: Koha depends on Clone (1013 bytes, patch)
2018-07-11 01:59 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 20949: Followup: debian/control (1.05 KB, patch)
2018-07-11 01:59 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2018-06-15 10:04:32 UTC
The ILL and SIP modules uses Clone. So far, libclone-perl was a dependency of a dependency, libhash-merge-perl. In Debian Buster and Ubuntu Bionic, libhash-merge-perl depends on libclone-choose-perl instead. Same problem for the plain Perl modules from CPAN. I file it under packaging anyway, I have to fix one to fix the other.
Comment 1 Mirko Tietgen 2018-06-15 10:05:36 UTC
*** Bug 18850 has been marked as a duplicate of this bug. ***
Comment 2 Mirko Tietgen 2018-06-15 10:37:17 UTC
Created attachment 76091 [details] [review]
Bug 20949: Koha depends on Clone

Clone was not declared a dependency before. It used to be a dependency
of Hash::Merge but isn't in the recent version.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 3 Mirko Tietgen 2018-06-15 10:37:32 UTC
Created attachment 76092 [details] [review]
Bug 20949: Followup: debian/control

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 4 Mirko Tietgen 2018-06-15 10:38:53 UTC
Nothing to test really. Check patch 1 if it makes sense, see effect for packaging in patch 2.
Comment 5 Mirko Tietgen 2018-07-03 08:26:15 UTC
Created attachment 76643 [details] [review]
Bug 20949: Koha depends on Clone

Clone was not declared a dependency before. It used to be a dependency
of Hash::Merge but isn't in the recent version.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 6 Mirko Tietgen 2018-07-03 08:26:31 UTC
Created attachment 76644 [details] [review]
Bug 20949: Followup: debian/control

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Comment 7 Katrin Fischer 2018-07-08 16:47:29 UTC
Created attachment 76773 [details] [review]
Bug 20949: Koha depends on Clone

Clone was not declared a dependency before. It used to be a dependency
of Hash::Merge but isn't in the recent version.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2018-07-08 16:47:33 UTC
Created attachment 76774 [details] [review]
Bug 20949: Followup: debian/control

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Chris Cormack 2018-07-11 01:59:30 UTC
Created attachment 76857 [details] [review]
Bug 20949: Koha depends on Clone

Clone was not declared a dependency before. It used to be a dependency
of Hash::Merge but isn't in the recent version.

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 10 Chris Cormack 2018-07-11 01:59:59 UTC
Created attachment 76858 [details] [review]
Bug 20949: Followup: debian/control

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 11 Nick Clemens 2018-07-13 11:25:30 UTC
Awesome work all!

Pushed to master for 18.11
Comment 12 Martin Renvoize 2018-07-15 18:58:15 UTC
Pushed to 18.05.x for 18.05.02
Comment 13 Fridolin SOMERS 2018-07-30 12:27:43 UTC
Pushed to 17.11.x for 17.11.09
Comment 14 Fridolin SOMERS 2018-07-30 12:28:46 UTC
No use of Clone (outise of test suite) in 17.05.x