Bug 20981 - Organization name missing from patron search results
Summary: Organization name missing from patron search results
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 18403
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-21 18:51 UTC by Owen Leonard
Modified: 2019-10-14 19:58 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 20981: Fix organization name when displaying patron's info (1.83 KB, patch)
2018-06-21 20:39 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 20981: Fix organization name when displaying patron's info (1.88 KB, patch)
2018-06-22 05:56 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2018-06-21 18:51:08 UTC
If I search for patrons limited by an institutional patron category, none of the results show a name. git bisect says this bug was introduced by Bug 18403, Use patron-title.inc when hidepatronname is used.
Comment 1 Jonathan Druart 2018-06-21 20:39:57 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2018-06-22 05:56:21 UTC
Created attachment 76249 [details] [review]
Bug 20981: Fix organization name when displaying patron's info

Caused by bug 18403.
From patron-title.inc, we need a IF instead of UNLESS.

Test plan:
Create organizations
Search for patrons
=> Without this patch the "Name" column is empty for organizations
=> With this patch applied you will see the surname (and othernames if
exists)

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 3 Katrin Fischer 2018-06-22 05:57:38 UTC
Moving to past QA - Martin, can you take this for 18.05.01 please? Changes a template, but no text changes, so should be ok for translations.
Comment 4 Nick Clemens 2018-06-22 13:50:27 UTC
Awesome work all!

Pushed to master for 18.11.x
Comment 5 Martin Renvoize 2018-06-25 17:32:20 UTC
Pushed to 18.05.x for 18.05.01