Bug 21019 - [17.11] Borrower address not shown on reserve pop-up on returns.pl
Summary: [17.11] Borrower address not shown on reserve pop-up on returns.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 17.11
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Tomás Cohen Arazi
URL:
Keywords:
Depends on: 17829
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-29 12:27 UTC by Nick Clemens
Modified: 2019-10-14 19:56 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21019: Fix display of patron's address on reserve pop-up on returns.pl (1.34 KB, patch)
2018-06-29 12:56 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21019: Fix display of patron's address on reserve pop-up on returns.pl (1.40 KB, patch)
2018-07-01 17:53 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 21019: Fix display of patron's address on reserve pop-up on returns.pl (1.45 KB, patch)
2018-07-02 19:28 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-06-29 12:27:29 UTC
Bug 17829 changed the variable for address from 'address' to 'boraddress' which is not used in the template
Comment 1 Jonathan Druart 2018-06-29 12:56:43 UTC
Created attachment 76562 [details] [review]
Bug 21019: Fix display of patron's address on reserve pop-up on returns.pl

Caused by
  commit 2b90ea2cb0e5e976de7ddef0151ae83d8ac578e6
  Bug 17829: Move GetMember to Koha::Patron

address variable has been replaced by boraddress (wrong resolution
conflict?)

It does not affect master (thanks bug 18789)

Test plan:
Confirm the address of the patron with a hold placed on the item is now
displayed when this item is checked in
Comment 2 Katrin Fischer 2018-07-01 17:53:42 UTC
Created attachment 76602 [details] [review]
Bug 21019: Fix display of patron's address on reserve pop-up on returns.pl

Caused by
  commit 2b90ea2cb0e5e976de7ddef0151ae83d8ac578e6
  Bug 17829: Move GetMember to Koha::Patron

address variable has been replaced by boraddress (wrong resolution
conflict?)

It does not affect master (thanks bug 18789)

Test plan:
Confirm the address of the patron with a hold placed on the item is now
displayed when this item is checked in

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 3 Tomás Cohen Arazi 2018-07-02 19:28:15 UTC
Created attachment 76642 [details] [review]
Bug 21019: Fix display of patron's address on reserve pop-up on returns.pl

Caused by
  commit 2b90ea2cb0e5e976de7ddef0151ae83d8ac578e6
  Bug 17829: Move GetMember to Koha::Patron

address variable has been replaced by boraddress (wrong resolution
conflict?)

It does not affect master (thanks bug 18789)

Test plan:
Confirm the address of the patron with a hold placed on the item is now
displayed when this item is checked in

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 4 Fridolin Somers 2018-07-03 07:23:20 UTC
Pushed to 17.11.x for 17.11.08

Ticky dependancy bug ;)