Bug 21030 - Date widget on suspend modal not working correctly
Summary: Date widget on suspend modal not working correctly
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 16242
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-02 16:52 UTC by Katrin Fischer
Modified: 2019-05-27 12:39 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21030: Date widget on suspend modal not working correctly (1.38 KB, patch)
2019-03-05 18:39 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21030: Date widget on suspend modal not working correctly (1.45 KB, patch)
2019-03-08 19:56 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 21030: Date widget on suspend modal not working correctly (1.52 KB, patch)
2019-03-09 20:41 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2018-07-02 16:52:12 UTC
The date widget on the modal for suspending holds is behaving strangely with the pull downs for seleting a month or year being unusable.

To test:
- Place a hold on an item
- Go to the patron account
- Click on the Suspend button on the holds tab
- Click on the calendar to enter a date
- Click on the pull downs for month and year, the pull downs don't open
- Verify the arrow buttons still work for moving between months
Comment 1 Jonathan Druart 2018-07-04 18:47:17 UTC
Confirmed on 17.05.13 (but certainly since 16.05)
Comment 2 Jonathan Druart 2018-07-04 18:57:36 UTC
I recreate on Firefox, not chromium
Comment 3 Jonathan Druart 2018-07-04 19:01:44 UTC
Owen, could you take a look at this one? I have no idea how to fix it.
Comment 4 Owen Leonard 2019-03-05 18:39:36 UTC
Created attachment 86111 [details] [review]
Bug 21030: Date widget on suspend modal not working correctly

This patch makes a change to the suspend hold modal markup in order to
allow the datepicker <selects> to work properly.

To test, apply the patch and locate a patron in the staff client who has
holds.

 - On the checkout or patron detail page, open the holds tab.
 - Click the "Suspend" button for one of the holds.
 - In the modal, trigger the date picker and confirm that the dropdowns
   for selecting month and year work correctly.
Comment 5 Pierre-Marc Thibault 2019-03-08 19:56:46 UTC
Created attachment 86400 [details] [review]
Bug 21030: Date widget on suspend modal not working correctly

This patch makes a change to the suspend hold modal markup in order to
allow the datepicker <selects> to work properly.

To test, apply the patch and locate a patron in the staff client who has
holds.

 - On the checkout or patron detail page, open the holds tab.
 - Click the "Suspend" button for one of the holds.
 - In the modal, trigger the date picker and confirm that the dropdowns
   for selecting month and year work correctly.

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 6 Katrin Fischer 2019-03-09 20:41:32 UTC
Created attachment 86414 [details] [review]
Bug 21030: Date widget on suspend modal not working correctly

This patch makes a change to the suspend hold modal markup in order to
allow the datepicker <selects> to work properly.

To test, apply the patch and locate a patron in the staff client who has
holds.

 - On the checkout or patron detail page, open the holds tab.
 - Click the "Suspend" button for one of the holds.
 - In the modal, trigger the date picker and confirm that the dropdowns
   for selecting month and year work correctly.

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Nick Clemens 2019-03-11 13:11:16 UTC
Awesome work all!

Pushed to master for 19.05
Comment 8 Martin Renvoize 2019-03-12 09:19:09 UTC
Pushed to 18.11.x for 18.11.04
Comment 9 Lucas Gass 2019-03-15 20:06:31 UTC
backported to 18.05.x for 18.05.11