Bug 21149 - Administrator creation in onboarding always fails
Summary: Administrator creation in onboarding always fails
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Jonathan Druart
QA Contact: Martin Renvoize
URL:
Keywords:
Depends on: 20287
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-02 14:34 UTC by Owen Leonard
Modified: 2019-10-14 19:56 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21149: Fix superlibrarian creation in onboarding (2.08 KB, patch)
2018-08-02 14:51 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21149: Fix superlibrarian creation in onboarding (2.13 KB, patch)
2018-08-02 16:09 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21149: Fix superlibrarian creation in onboarding (2.20 KB, patch)
2018-08-03 21:11 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2018-08-02 14:34:20 UTC
During the onboarding process in installation, the creation of an Administrator patron always fails with the error, "The patron has not been created! Cardnumber or Userid may already exist."

git bisect blames Bug 20287: Move AddMember to Koha::Patron->store
Comment 1 Jonathan Druart 2018-08-02 14:51:31 UTC
Created attachment 77447 [details] [review]
Bug 21149: Fix superlibrarian creation in onboarding

See bug 21087 for more details.

Test plan:
Drop your DB
Start the installation process
Use the onboarding process to install missing data
The superlibrarian created during this process should be created
sucessfully and allowed to login
Comment 2 Jonathan Druart 2018-08-02 14:52:24 UTC
I wrote bug 19185 to catch issues during the install/onboarding process
Comment 3 Owen Leonard 2018-08-02 16:09:02 UTC
Created attachment 77450 [details] [review]
Bug 21149: Fix superlibrarian creation in onboarding

See bug 21087 for more details.

Test plan:
Drop your DB
Start the installation process
Use the onboarding process to install missing data
The superlibrarian created during this process should be created
sucessfully and allowed to login

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 Martin Renvoize 2018-08-03 21:11:24 UTC
Created attachment 77485 [details] [review]
Bug 21149: Fix superlibrarian creation in onboarding

See bug 21087 for more details.

Test plan:
Drop your DB
Start the installation process
Use the onboarding process to install missing data
The superlibrarian created during this process should be created
sucessfully and allowed to login

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2018-08-03 21:12:54 UTC
Works as expected and no failures on the qa scripts. Looks good to me, Passing QA
Comment 6 Martin Renvoize 2018-08-03 21:51:49 UTC
I have the selenium tests bug and it's dependency of the separate db's for testing on my list for early next week.  Lets get some tests in place to prevent a re-occurrence :)
Comment 7 Nick Clemens 2018-08-08 21:34:26 UTC
Awesome work all!

Pushed to master for 18.11
Comment 8 Martin Renvoize 2018-08-09 10:04:46 UTC
Depends on (and is caused by) but 20287 which is not in 18.05.x series.