Bug 2122 - Grayed out Fields not always visible
Summary: Grayed out Fields not always visible
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) trivial (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-16 03:30 UTC by Nicole C. Engard
Modified: 2012-10-25 23:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
king, stephen is authorized and i cannot edit - but it looks white to me (24.75 KB, image/png)
2008-05-17 08:26 UTC, Chris Cormack
Details
on pc in firefox (same browser) it's gray (31.58 KB, image/png)
2008-05-17 08:32 UTC, Chris Cormack
Details
Screenshot of proposed update (12.33 KB, image/png)
2010-08-05 13:47 UTC, Owen Leonard
Details
Proposed fix (3.37 KB, patch)
2010-08-06 19:17 UTC, Owen Leonard
Details | Diff | Splinter Review
Follow-up fix for authorities editor (1.42 KB, patch)
2010-11-15 14:57 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:46:49 UTC


---- Reported by nengard@gmail.com 2008-05-16 03:30:03 ----

On my MAC (with Firefox) I don't even see that the authorized fields in the cataloging module are gray - I only knew it was gray because I saw it on someone else's PC (so I had no idea I couldn't edit it until my delete button wasn't responding)

    * GMC: noted - worth filing a Koha enhancement and checking with Owen about how to improve display.



---- Additional Comments From oleonard@myacpl.org 2008-05-16 18:33:14 ----

I could use a screenshot on this one and/or steps to reproduce.



---- Additional Comments From nengard@gmail.com 2008-05-17 08:26:49 ----

Created an attachment
king, stephen is authorized and i cannot edit - but it looks white to me





---- Additional Comments From nengard@gmail.com 2008-05-17 08:32:43 ----

Created an attachment
on pc in firefox (same browser) it's gray





---- Additional Comments From nengard@gmail.com 2008-05-17 08:33:32 ----

The first is on a MAC with Firefox and the second is on a PC with Firefox - both the same version of Firefox (what ever is newest - but not beta).  MAC is OS X and PC is Windows XP.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:46 UTC  ---

This bug was previously known as _bug_ 2122 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2122
Imported an attachment (id=507)
Imported an attachment (id=508)

Actual time not defined. Setting to 0.0
CC member bchurch@ptfs.com does not have an account here
The original submitter of attachment 507 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 508 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-08-05 13:47:37 UTC
Created attachment 2470 [details]
Screenshot of proposed update

My proposed solution would add a "readonly" class to these inputs since we can't depend on browsers to consistently indicate the readonly attribute with a default color.

I also thought adding a "locked" icon might be a good way to indicate that the field is read only.
Comment 2 Nicole C. Engard 2010-08-05 13:48:51 UTC
I like the way this looks! It makes it very clear.
Comment 3 Owen Leonard 2010-08-06 19:17:07 UTC
Created attachment 2480 [details] [review]
Proposed fix

- Adding "readonly" class to readonly fields to guarantee that readonly state is indicated visually
- Adding "locked" icon to the background of readonly fields for additional visual feedback
Comment 4 Galen Charlton 2010-11-15 13:03:22 UTC
I've signed off on the patch.  The authority record editor should get a parallel change.
Comment 5 Owen Leonard 2010-11-15 14:57:01 UTC
Created attachment 2756 [details] [review]
Follow-up fix for authorities editor

This patch depends on the previously submitted patch for the MARC editor
Comment 6 Chris Cormack 2010-11-17 08:23:46 UTC
Patches pushed, please test
Comment 7 Chris Nighswonger 2010-11-18 03:15:20 UTC
This bug has a patch presently committed to HEAD and 3.2.x.

Please take the appropriate action to update the status of this bug.

Remember, bugs which have been resolved should be tested and marked closed, preferably by the original reporter.
Comment 8 Chris Nighswonger 2010-11-30 13:49:23 UTC
This bug has a fix which was committed to the 3.2.x branch and released in 3.2.1.

Please take time to update the status of this bug and mark it RESOLVED FIXED so that it may be closed.
Comment 9 MJ Ray (software.coop) 2010-12-10 10:22:53 UTC
This bug is mentioned in:
Fix for Bug 2122,	Grayed out Fields not always visible http://lists.koha-community.org/pipermail/koha-patches/2010-November/013012.html
Bug 2122 follow-up for authorities editor http://lists.koha-community.org/pipermail/koha-patches/2010-November/013014.html
Bug 2122 follow-up for	authorities editor http://lists.koha-community.org/pipermail/koha-patches/2010-November/013029.html