Bug 21292 - Patron Deletion Tool
Summary: Patron Deletion Tool
Status: RESOLVED DUPLICATE of bug 24483
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: 17.11
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-30 15:22 UTC by Kelly McElligott
Modified: 2020-07-20 14:19 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
this is what Koha produces from a patron list of 3 people when only 1 could be deleted. (19.57 KB, image/png)
2018-08-30 15:22 UTC, Kelly McElligott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kelly McElligott 2018-08-30 15:22:35 UTC
Created attachment 78312 [details]
this is what Koha produces from a patron list of 3 people when only 1 could be deleted.

Currently, the patron deletion tool will not delete patrons who has fines and/or checkouts.  Unfortunately, the tool does not indicate the patrons that were not deleted because of these constraints.  It would be nice to have Koha identify the # of patrons that were requested to be deleted, the number of patrons successfully deleted (with possibly a list) and the number and specifics of the patrons that could not be deleted due to checkouts/fines. This would give clear indication what was accomplished with this tool for libraries.  The current functionality of entering patrons that have checkouts/fines that have been requested to be deleted, Koha all but ignores those patrons and doesn't say anything.  For example, if I had a patron list of 3 patrons and I requested Koha delete this entire list of patrons.  If 2 of those patrons had fines/checkouts, Koha would only display 1 patron deleted.  This would not be a link to the patron that was deleted - just a simple number.  

In addition, the manual does not have correct information regarding this tool - as it indicates - this is quoted from the 17.11 manual : 

"Important

Patrons with outstanding fines or items checked out are not saved. They are not completely removed from the system (they are only moved to the delete_borrowers table), but this tool does not provide as many checks as one may desire."
Comment 1 Caroline Cyr La Rose 2020-07-20 14:18:25 UTC

*** This bug has been marked as a duplicate of bug 24483 ***
Comment 2 Caroline Cyr La Rose 2020-07-20 14:19:55 UTC
I marked this one as duplicate of 24483 even though it's newer because the title is more specific and the description has a test plan.