Bug 2131 - Enhanced Content - Multiple Choices
Summary: Enhanced Content - Multiple Choices
Status: RESOLVED DUPLICATE of bug 7187
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-19 06:17 UTC by Nicole C. Engard
Modified: 2014-08-17 21:37 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:46:55 UTC


---- Reported by nengard@gmail.com 2008-05-19 06:17:54 ----

With Google, Amazon, Baker & Taylor - there should be a way for the system to look at one and then the other.  If not, then Amazon and B&T should be broken down into covers and other sources so that users can pick where they want their covers from.  Right now if they want covers from Google, but content from Amazon they can't do that.

<nengard> googlejackets question - can you have this and other services on at the same time? or just one?
 <owen> Just one at the moment.
 <owen> kados has mentioned that he'd like the system to have fallbacks built in, but not yet there.
 <lloyd_> mm that'd be good
 <lloyd_> OS friendly google first, failover to clickthrough hungry amazon
 <owen> Hmm... we lost newlogbot again :(
 <nengard> owen does that mean it only picks from one?
 <nengard> if they're all on - which dominates
 <owen> nengard: Good question. You're only supposed to pick one. Obviously that's a usability issue.
 <owen> Our system preferences need a way to show dependencies.
 <owen> Then the book jackets could be a choice-type syspref, and it could warn you of dependencies.
 * paul_koha is now known as paul
 <nengard> owen - i have a problem - if I have on amazon content that's all content - covers + 
 <nengard> google is just jackets
 <nengard> there is no way to have google jackets and amazon reviews
 <owen> Yeah...I think the assumption is that you're picking one or the other (for instance, because you don't like incorporating Amazon content in your OPAC)
 <nengard> hmmm - okay
 <owen> Feel free to file an enhancement bug for that :)
 <nengard> will do



---- Additional Comments From nengard@gmail.com 2009-08-25 16:43:15 ----

Is this now possible?



---- Additional Comments From danny.bouman@hclibrary.org 2009-08-27 15:48:17 ----

My original patch for allowing multiple enhanced cover providers to be turned on was rejected because it didn't include support for JavaScript disabled. I have not yet had a chance to re-work the patch and resubmit it. If anyone else would like to take on this task, please feel free to do so. Otherwise, I am happy to take on this task when time allows me to turn my eyes back to this enhancement.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:46 UTC  ---

This bug was previously known as _bug_ 2131 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2131

Actual time not defined. Setting to 0.0
CC member bchurch@ptfs.com does not have an account here
CC member danny.bouman@hclibrary.org does not have an account here
CC member jmf@liblime.com does not have an account here

Comment 1 Owen Leonard 2011-07-25 14:52:37 UTC
The "original patch" referred to above:

http://lists.koha-community.org/pipermail/koha-patches/2009-February/008273.html
Comment 2 Katrin Fischer 2014-08-17 21:37:03 UTC

*** This bug has been marked as a duplicate of bug 7187 ***