Bug 21324 - Missing aoColumns definition in acqui/parcel receivedt table
Summary: Missing aoColumns definition in acqui/parcel receivedt table
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on: 18639
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-07 10:06 UTC by paxed
Modified: 2019-10-14 19:56 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21324: Fix column defs and spans (2.47 KB, patch)
2018-09-07 11:35 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21324: Fix column defs and spans (2.52 KB, patch)
2018-09-07 12:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21324: Fix column defs and spans (2.59 KB, patch)
2018-09-14 09:39 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2018-09-07 10:06:04 UTC
Bug 18639 added a column to the receivedt table in acqui/parcel, but did not add an aoColumns definition for the column. This breaks the javascript on the page.

And the receivedt table totals at the bottom don't match the columns.
Comment 1 Nick Clemens 2018-09-07 11:35:55 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2018-09-07 12:11:56 UTC
Created attachment 78514 [details] [review]
Bug 21324: Fix column defs and spans

TO test:
1 - Open a bastket in acquisitions
2 - Order some items
3 - Close the basket
4 - Receive some items
5 - Note the columns are out of alingment on parcel.pl
6 - Note a JS error breaking datatable on 'Already received'
7 - Apply patch
8 - Things should be better

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Julian Maurice 2018-09-14 09:39:01 UTC
Created attachment 78642 [details] [review]
Bug 21324: Fix column defs and spans

TO test:
1 - Open a bastket in acquisitions
2 - Order some items
3 - Close the basket
4 - Receive some items
5 - Note the columns are out of alingment on parcel.pl
6 - Note a JS error breaking datatable on 'Already received'
7 - Apply patch
8 - Things should be better

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>
Comment 4 Nick Clemens 2018-09-14 19:58:05 UTC
Awesome work all!

Pushed to master for 18.11
Comment 5 Martin Renvoize 2018-09-17 13:15:58 UTC
Caused by bug 18639 not in 18.05.x series.