Bug 21505 - Box around 'Additional fields' does not contain the fields
Summary: Box around 'Additional fields' does not contain the fields
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 21523
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-05 19:24 UTC by Caroline Cyr La Rose
Modified: 2018-11-28 09:31 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Additional fields box (30.08 KB, image/png)
2018-10-05 19:24 UTC, Caroline Cyr La Rose
Details
Bug 21505: Box around 'Additional fields' does not contain the fields (1.97 KB, patch)
2018-10-09 18:19 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21505: Box around 'Additional fields' does not contain the fields (2.03 KB, patch)
2018-10-11 10:09 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 21505: Box around 'Additional fields' does not contain the fields (2.08 KB, patch)
2018-10-11 20:11 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Caroline Cyr La Rose 2018-10-05 19:24:12 UTC
Created attachment 80147 [details]
Additional fields box

When you have additional fields in your subscription, the 'Additional fields' title appears in a blue box, but the fields themselves are outside the box.(See attached screen capture)

To reproduce:
1) Go to Serials
2) Click on 'Add subscription fields'
3) Click on 'New fields'
4) Fill in the form and click 'Save'
5) Search for a subscription
6) Click on the title to see the subscription detail page
7) In the 'Information' tab, there is the 'Additional fields' title in its box followed by the additional field
Comment 1 Caroline Cyr La Rose 2018-10-05 19:25:22 UTC
Maybe also change the 'New fields' for 'New field'. All the 'New ...' buttons are singular, and we only add one field at a time.
Comment 2 Owen Leonard 2018-10-09 18:19:02 UTC
Created attachment 80303 [details] [review]
Bug 21505: Box around 'Additional fields' does not contain the fields

This patch modifies the subscription detail page markup to eliminate a
confusing bordered <legend> tag. It is replaced with an <hr> to
delineate the sections and an <h3> tag to serve as the heading.

To test, apply the patch and regenerate the staff client CSS.

 - Configure one or more additional subscription fields.
 - View the detail page for a subscription and confirm that the
   "Additional fields" section is clearly labeled.
Comment 3 Owen Leonard 2018-10-10 11:59:46 UTC
(In reply to Caroline Cyr La Rose from comment #1)
> Maybe also change the 'New fields' for 'New field'. All the 'New ...'
> buttons are singular, and we only add one field at a time.

I created Bug 21531 for this issue.
Comment 4 Claire Gravely 2018-10-11 10:09:00 UTC
Created attachment 80392 [details] [review]
Bug 21505: Box around 'Additional fields' does not contain the fields

This patch modifies the subscription detail page markup to eliminate a
confusing bordered <legend> tag. It is replaced with an <hr> to
delineate the sections and an <h3> tag to serve as the heading.

To test, apply the patch and regenerate the staff client CSS.

 - Configure one or more additional subscription fields.
 - View the detail page for a subscription and confirm that the
   "Additional fields" section is clearly labeled.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 5 Katrin Fischer 2018-10-11 20:10:39 UTC
I like this much better, thx!
Comment 6 Katrin Fischer 2018-10-11 20:11:12 UTC
Created attachment 80423 [details] [review]
Bug 21505: Box around 'Additional fields' does not contain the fields

This patch modifies the subscription detail page markup to eliminate a
confusing bordered <legend> tag. It is replaced with an <hr> to
delineate the sections and an <h3> tag to serve as the heading.

To test, apply the patch and regenerate the staff client CSS.

 - Configure one or more additional subscription fields.
 - View the detail page for a subscription and confirm that the
   "Additional fields" section is clearly labeled.

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Nick Clemens 2018-10-19 17:33:10 UTC
Awesome work all!

Pushed to master for 18.11
Comment 8 Martin Renvoize 2018-11-06 10:15:51 UTC
Caused by bug 21523 not in 18.05.x series.
Comment 9 Martin Renvoize 2018-11-06 11:00:59 UTC
Ignore that.. the error is present in 18.05.x series too.. backporting now.
Comment 10 Martin Renvoize 2018-11-06 11:08:36 UTC
Pushed to 18.05.x for 18.05.06
Comment 11 Fridolin SOMERS 2018-11-28 09:31:04 UTC
I prefer not to change display in 17.11.x