Bug 21536 - t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled
Summary: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Mirko Tietgen
QA Contact: Martin Renvoize
URL:
Keywords:
Depends on: 17602
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-10 14:15 UTC by Mirko Tietgen
Modified: 2018-10-15 17:18 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21536: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled (1.04 KB, patch)
2018-10-10 14:18 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 21536: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled (1.29 KB, patch)
2018-10-12 13:34 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21536: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled (1.36 KB, patch)
2018-10-12 14:11 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Tietgen 2018-10-10 14:15:42 UTC
t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled if WebService::ILS is not available.
Comment 1 Mirko Tietgen 2018-10-10 14:18:31 UTC
Created attachment 80353 [details] [review]
Bug 21536: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled

t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled
if WebService::ILS is not available.
Comment 2 Mirko Tietgen 2018-10-10 14:26:01 UTC
Test plan:
- have a system without Webservice::ILS available
- in koha-shell, do 
  prove t/Koha_ExternalContent_RecordedBooks.t
- tests should be skipped and tests count as "passed"
Comment 3 Jonathan Druart 2018-10-12 13:34:50 UTC
Created attachment 80476 [details] [review]
Bug 21536: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled

t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled
if WebService::ILS is not available.

Test plan:
- have a system without Webservice::ILS available
- in koha-shell, do
  prove t/Koha_ExternalContent_RecordedBooks.t
- tests should be skipped and tests count as "passed"

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Martin Renvoize 2018-10-12 14:11:37 UTC
Created attachment 80502 [details] [review]
Bug 21536: t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled

t/Koha_ExternalContent_RecordedBooks.t skips more tests than scheduled
if WebService::ILS is not available.

Test plan:
- have a system without Webservice::ILS available
- in koha-shell, do
  prove t/Koha_ExternalContent_RecordedBooks.t
- tests should be skipped and tests count as "passed"

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2018-10-12 14:12:03 UTC
Trivial patch, works as expected. Passing QA.
Comment 6 Tomás Cohen Arazi 2018-10-12 18:36:24 UTC
Pushed for 18.11. Thanks all!
Comment 7 Martin Renvoize 2018-10-15 17:18:59 UTC
Caused by bug 17602 not in 18.05.x series.