Bug 21579 - showdiffmarc tool during manage staged batches always looks for biblios even when matching authorities
Summary: showdiffmarc tool during manage staged batches always looks for biblios even ...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 15026 16954 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-16 14:00 UTC by Nick Clemens
Modified: 2018-11-28 15:37 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 21579: Make showdiffmarc.pl work for authorities and biblios (4.74 KB, patch)
2018-10-16 14:03 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21579: Make showdiffmarc.pl work for authorities and biblios (4.81 KB, patch)
2018-10-16 15:02 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 21579: Make showdiffmarc.pl work for authorities and biblios (4.86 KB, patch)
2018-10-16 18:04 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 21579: Make showdiffmarc.pl work for authorities and biblios (4.95 KB, patch)
2018-10-16 20:47 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-10-16 14:00:54 UTC
The code in general here doesn't seem to know about authorities
Comment 1 Nick Clemens 2018-10-16 14:03:28 UTC
Created attachment 80654 [details] [review]
Bug 21579: Make showdiffmarc.pl work for authorities and biblios

To test:
 1 - Have or make some authority records
 2 - Have or make an authority matching rule
 3 - Export your authrotities
 4 - Import them using the matching rule
 5 - On the 'Manage staged records' page view some diffs
 6 - The import record is correct, but the existing records pull form
 bibs
 7 - Apply patch
 8 - Repeat
 9 - Confirm you see the expected authority matches
Comment 2 M. Tompsett 2018-10-16 15:02:12 UTC
Created attachment 80657 [details] [review]
Bug 21579: Make showdiffmarc.pl work for authorities and biblios

To test:
 1 - Have or make some authority records
 2 - Have or make an authority matching rule
 3 - Export your authrotities
 4 - Import them using the matching rule
 5 - On the 'Manage staged records' page view some diffs
 6 - The import record is correct, but the existing records pull form
 bibs
 7 - Apply patch
 8 - Repeat
 9 - Confirm you see the expected authority matches

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Comment 3 Katrin Fischer 2018-10-16 17:39:11 UTC
Possible duplicate with bug 16954?
Comment 4 Katrin Fischer 2018-10-16 17:40:11 UTC
*** Bug 16954 has been marked as a duplicate of this bug. ***
Comment 5 sandboxes@biblibre.com 2018-10-16 18:04:13 UTC
Patch tested with a sandbox, by Marjorie Vila <marjorie.barry-vila@collecto.ca>
Comment 6 sandboxes@biblibre.com 2018-10-16 18:04:43 UTC
Created attachment 80674 [details] [review]
Bug 21579: Make showdiffmarc.pl work for authorities and biblios

To test:
 1 - Have or make some authority records
 2 - Have or make an authority matching rule
 3 - Export your authrotities
 4 - Import them using the matching rule
 5 - On the 'Manage staged records' page view some diffs
 6 - The import record is correct, but the existing records pull form
 bibs
 7 - Apply patch
 8 - Repeat
 9 - Confirm you see the expected authority matches

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Marjorie Vila <marjorie.barry-vila@collecto.ca>
Comment 7 Jonathan Druart 2018-10-16 20:46:38 UTC
+        diff_url => $match_id ? "/cgi-bin/koha/tools/showdiffmarc.pl?batchid=$import_batch_id&importid=$record->{import_record_id}&id=$match_id&type=$record->{record_type}" : undef

This is wrong, we should build the URL template-side, but existed prior to this patch.
Comment 8 Jonathan Druart 2018-10-16 20:47:05 UTC
Created attachment 80682 [details] [review]
Bug 21579: Make showdiffmarc.pl work for authorities and biblios

To test:
 1 - Have or make some authority records
 2 - Have or make an authority matching rule
 3 - Export your authrotities
 4 - Import them using the matching rule
 5 - On the 'Manage staged records' page view some diffs
 6 - The import record is correct, but the existing records pull form
 bibs
 7 - Apply patch
 8 - Repeat
 9 - Confirm you see the expected authority matches

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Marjorie Vila <marjorie.barry-vila@collecto.ca>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 9 Nick Clemens 2018-10-17 19:26:13 UTC
Awesome work all!

Pushed to master for 18.11
Comment 10 Martin Renvoize 2018-10-26 11:50:05 UTC
Pushed to 18.05.x for 18.05.06
Comment 11 Fridolin SOMERS 2018-11-09 14:04:39 UTC
Pushed to 17.11.x for 17.11.12
Comment 12 Nick Clemens 2018-11-15 16:16:30 UTC
*** Bug 15026 has been marked as a duplicate of this bug. ***