Bug 2188 - Accounts.pm outputs untranslatable English strings
Summary: Accounts.pm outputs untranslatable English strings
Status: CLOSED DUPLICATE of bug 2546
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: 3.4
Hardware: All All
: P3 major (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-31 11:59 UTC by Owen Leonard
Modified: 2012-10-26 00:40 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:47:35 UTC


---- Reported by oleonard@myacpl.org 2008-05-31 11:59:00 ----

Accounts.pm relies on matching letter codes to hard-coded descriptions:

    if ( $type eq 'N' ) {
        $desc .= " New Card";
    }

These descriptions are concatenated by the script with user-generated descriptions (hence http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2183). I don't know enough about fines management to know if it's possible, but the obvious answer here would be to use authorized values.



---- Additional Comments From jmf@liblime.com 2008-07-08 21:12:16 ----

Yep, this is a good one, but I'm gonna delay it for rel_3_2, we've got bigger fish to fry



---- Additional Comments From nengard@gmail.com 2009-12-23 17:59:01 ----

This bug hasn't been touched in nearly a year, please revisit and test and close if appropriate.



---- Additional Comments From oleonard@myacpl.org 2009-12-28 14:13:48 ----

Confirmed that this code still exists in Accounts.pm.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:47 UTC  ---

This bug was previously known as _bug_ 2188 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2188

Actual time not defined. Setting to 0.0

Comment 1 Colin Campbell 2010-06-22 09:34:17 UTC
Note: the strings are saved in the description column of the accountlines table.
Comment 2 Owen Leonard 2010-09-17 14:18:56 UTC

*** This bug has been marked as a duplicate of bug 2546 ***