Bug 21900 - intranet_catalog_biblio_enhancements_toolbar_button plugin hook broken
Summary: intranet_catalog_biblio_enhancements_toolbar_button plugin hook broken
Status: RESOLVED DUPLICATE of bug 21905
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Andrew Isherwood
QA Contact: Testopia
URL:
Keywords:
Depends on: 20968
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-28 13:49 UTC by Andrew Isherwood
Modified: 2018-11-29 08:43 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21900: Fix erroneous filter (1.53 KB, patch)
2018-11-28 13:52 UTC, Andrew Isherwood
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Isherwood 2018-11-28 13:49:03 UTC
Commit 1a0172a253e5432e5eef862768aaacb3463501f2 broke the display of buttons provided by plugins making use of the intranet_catalog_biblio_enhancements_toolbar_button hook. The addition of the html filter breaks the ability of the browser to parse the HTML provided by the plugin, the $raw filter needs to be used instead.
Comment 1 Andrew Isherwood 2018-11-28 13:52:53 UTC
Created attachment 82700 [details] [review]
Bug 21900: Fix erroneous filter

Swap the filter from html to $raw. We need the browser to be able to
parse the HTML supplied by plugins.

Test plan:
- Apply patch
- Install plugin that uses the
intranet_catalog_biblio_enhancements_toolbar_button hook, currently only https://github.com/PTFS-Europe/koha-plugin-cla-check_permissions/releases
- View the /cgi-bin/koha/catalogue/detail.pl page for an record
=> TEST: Verify that the "CLA Check Permissions" button is displaying in
the record's tool bar
Comment 2 Andrew Isherwood 2018-11-29 08:43:13 UTC
Bug 21905 also addresses this problem and has a test plan involving the easier to test Kitchen Sink plugin. So I'm closing this one in favour of that one.

*** This bug has been marked as a duplicate of bug 21905 ***