Bug 21926 - Enhance OAI-PMH:archiveID system preference description
Summary: Enhance OAI-PMH:archiveID system preference description
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Target Milestone: ---
Assignee: Josef Moravec
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 22133 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-30 10:26 UTC by Josef Moravec
Modified: 2019-02-12 15:33 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21926: Enhance OAI-PMH:archiveID system preference description (1.44 KB, patch)
2018-11-30 10:34 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 21926: Enhance OAI-PMH:archiveID system preference description (1.49 KB, patch)
2018-12-05 16:04 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 21926: Enhance OAI-PMH:archiveID system preference description (1.54 KB, patch)
2018-12-05 20:52 UTC, Michal Denar
Details | Diff | Splinter Review
Bug 21926: Enhance OAI-PMH:archiveID system preference description (1.65 KB, patch)
2019-01-16 20:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2018-11-30 10:26:35 UTC

    
Comment 1 Josef Moravec 2018-11-30 10:34:33 UTC
Created attachment 82774 [details] [review]
Bug 21926: Enhance OAI-PMH:archiveID system preference description

Test plan:
1) Apply the patch
2) Go to Administration -> System preferences -> Web services, section
OAI-PMH
3) See description on OAI-PMH:archiveID and confirm it does make sense
and have the link to implementation guidelines
Comment 2 Owen Leonard 2018-12-05 15:14:05 UTC
+            - ": . The archiveID should respect OAI specification. See "

I think the ": " needs to be removed here while you're making changes. I don't see why it's there.
Comment 3 Josef Moravec 2018-12-05 16:03:44 UTC
(In reply to Owen Leonard from comment #2)
> +            - ": . The archiveID should respect OAI specification. See "
> 
> I think the ": " needs to be removed here while you're making changes. I
> don't see why it's there.

As I understand it, the colon is here to show that it is not needed to insert it into the form field...

But it could be improved. I'll try something...
Comment 4 Josef Moravec 2018-12-05 16:04:08 UTC
Created attachment 82875 [details] [review]
Bug 21926: Enhance OAI-PMH:archiveID system preference description

Test plan:
1) Apply the patch
2) Go to Administration -> System preferences -> Web services, section
OAI-PMH
3) See description on OAI-PMH:archiveID and confirm it does make sense
and have the link to implementation guidelines
Comment 5 Michal Denar 2018-12-05 20:52:07 UTC
Created attachment 82892 [details] [review]
Bug 21926: Enhance OAI-PMH:archiveID system preference description

Test plan:
1) Apply the patch
2) Go to Administration -> System preferences -> Web services, section
OAI-PMH
3) See description on OAI-PMH:archiveID and confirm it does make sense
and have the link to implementation guidelines

Signed-off-by: Michal Denar <black23@gmail.com>
Comment 6 Katrin Fischer 2019-01-16 20:50:44 UTC
Created attachment 84090 [details] [review]
Bug 21926: Enhance OAI-PMH:archiveID system preference description

Test plan:
1) Apply the patch
2) Go to Administration -> System preferences -> Web services, section
OAI-PMH
3) See description on OAI-PMH:archiveID and confirm it does make sense
and have the link to implementation guidelines

Signed-off-by: Michal Denar <black23@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Tomás Cohen Arazi 2019-01-18 10:37:30 UTC
*** Bug 22133 has been marked as a duplicate of this bug. ***
Comment 8 Nick Clemens 2019-01-28 16:10:51 UTC
Awesome work all!

Pushed to master for 19.05
Comment 9 Martin Renvoize 2019-02-01 14:38:42 UTC
Enhancement, will not be backported to 18.11.x series.
Comment 10 Martin Renvoize 2019-02-01 14:40:37 UTC
I changed my mind.. this is a worthwhile improvement to documentation early enough in the cycle that I think it can slide in.. Pushed to 18.11.x for 18.11.03
Comment 11 Jesse Maseto 2019-02-06 18:06:30 UTC
Pushed to 18.05.x for 18.05.09
Comment 12 Fridolin SOMERS 2019-02-12 15:33:21 UTC
I prefer not push to 17.11.x to avoid translation work