Bug 21962 - The `searching entire record` option in authority searches is currently failing
Summary: The `searching entire record` option in authority searches is currently failing
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: master
Hardware: All All
: P1 - high major with 10 votes (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
: 22040 (view as bug list)
Depends on: 21581
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-06 12:34 UTC by Nick Clemens
Modified: 2019-02-25 06:53 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21962: Unit tests (1.13 KB, patch)
2018-12-06 12:48 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21962: Fix authority search using 'all' (1.10 KB, patch)
2018-12-06 12:48 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 21962: Unit tests (1.19 KB, patch)
2018-12-07 19:48 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 21962: Fix authority search using 'all' (1.17 KB, patch)
2018-12-07 19:48 UTC, Pierre-Marc Thibault
Details | Diff | Splinter Review
Bug 21962: Unit tests (1.27 KB, patch)
2018-12-10 20:29 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 21962: Fix authority search using 'all' (1.25 KB, patch)
2018-12-10 20:30 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-12-06 12:34:10 UTC
Bug 21581 allowed passing custom indexes through the authorities search, however, we failed to catch the case where 'attr1 = all' was converted to 'Any'
Comment 1 Nick Clemens 2018-12-06 12:48:50 UTC
Created attachment 82905 [details] [review]
Bug 21962: Unit tests
Comment 2 Nick Clemens 2018-12-06 12:48:53 UTC
Created attachment 82906 [details] [review]
Bug 21962: Fix authority search using 'all'

To test:
1 - Set search engine to Zebra
2 - Have some authorities and indexes up to date
3 - Search authorities with option 'search entire record'
4 - No results
5 - Apply patch
6 - Run unit tests, they pass!
7 - Repeat search
8 - Results!
Comment 3 Pierre-Marc Thibault 2018-12-07 19:48:01 UTC
Created attachment 82999 [details] [review]
Bug 21962: Unit tests

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 4 Pierre-Marc Thibault 2018-12-07 19:48:04 UTC
Created attachment 83000 [details] [review]
Bug 21962: Fix authority search using 'all'

To test:
1 - Set search engine to Zebra
2 - Have some authorities and indexes up to date
3 - Search authorities with option 'search entire record'
4 - No results
5 - Apply patch
6 - Run unit tests, they pass!
7 - Repeat search
8 - Results!

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>
Comment 5 Jonathan Druart 2018-12-10 20:29:57 UTC
Created attachment 83031 [details] [review]
Bug 21962: Unit tests

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 6 Jonathan Druart 2018-12-10 20:30:02 UTC
Created attachment 83032 [details] [review]
Bug 21962: Fix authority search using 'all'

To test:
1 - Set search engine to Zebra
2 - Have some authorities and indexes up to date
3 - Search authorities with option 'search entire record'
4 - No results
5 - Apply patch
6 - Run unit tests, they pass!
7 - Repeat search
8 - Results!

Signed-off-by: Pierre-Marc Thibault <pierre-marc.thibault@inLibro.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Nick Clemens 2018-12-11 20:59:49 UTC
Awesome work all!

Pushed to master for 19.05
Comment 8 Martin Renvoize 2018-12-12 10:51:45 UTC
Pushed to 18.11.x for 18.11.01
Comment 9 Jesse Maseto 2018-12-18 19:25:03 UTC
Pushed to 18.05.x for 18.05.07
Comment 10 Jonathan Druart 2018-12-21 15:11:37 UTC
*** Bug 22040 has been marked as a duplicate of this bug. ***
Comment 11 Fridolin SOMERS 2019-01-02 09:09:21 UTC
Pushed to 17.11.x for 17.11.14

Note that backport to 18.05.x created a followup :
Bug 21962: (RMaint follow-up) Fixed bad rebase.