Bug 21965 - Switch two-column templates to Bootstrap grid: Patrons part 3
Summary: Switch two-column templates to Bootstrap grid: Patrons part 3
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 21967 (view as bug list)
Depends on:
Blocks: 20654
  Show dependency treegraph
 
Reported: 2018-12-06 14:10 UTC by Owen Leonard
Modified: 2019-01-31 16:58 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 21965: Update two-column templates with Bootstrap grid: Patrons part 3 (13.70 KB, patch)
2018-12-06 15:02 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 21965: Update two-column templates with Bootstrap grid: Patrons part 3 (13.75 KB, patch)
2018-12-17 14:21 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 21965: Update two-column templates with Bootstrap grid: Patrons part 3 (13.87 KB, patch)
2018-12-17 21:12 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2018-12-06 14:10:01 UTC
These two-column patron templates can be updated to use the Bootstrap grid.

 - members/notices.tt
 - members/pay.tt
 - members/paycollect.tt
 - members/purchase-suggestions.tt
 - members/readingrec.tt
 - members/routing-lists.tt
 - members/statistics.tt
Comment 1 Owen Leonard 2018-12-06 15:02:32 UTC
Created attachment 82912 [details] [review]
Bug 21965: Update two-column templates with Bootstrap grid: Patrons part 3

This patch modifies several patron templates to use the Bootstrap grid
instead of YUI.

This patch also removes obsolete "text/javascript" attributes from
<script> tags and "text/css" attributes from <style> tags in the
modified templates.

Markup has been corrected in paycollect.tt and readingrec.tt where a
table row lacked <tr>.

To test, apply the patch and view the following pages, confirming that
they look correct at various browser widths:

 - Patron -> Notices
 - Patron -> Purchase suggestions
 - Patron -> Circulation history
 - Patron -> Routing lists
 - Patron -> Statistics
 - Patron -> Fines
   -> Pay
Comment 2 Claire Gravely 2018-12-17 14:21:54 UTC
Created attachment 83290 [details] [review]
Bug 21965: Update two-column templates with Bootstrap grid: Patrons part 3

This patch modifies several patron templates to use the Bootstrap grid
instead of YUI.

This patch also removes obsolete "text/javascript" attributes from
<script> tags and "text/css" attributes from <style> tags in the
modified templates.

Markup has been corrected in paycollect.tt and readingrec.tt where a
table row lacked <tr>.

To test, apply the patch and view the following pages, confirming that
they look correct at various browser widths:

 - Patron -> Notices
 - Patron -> Purchase suggestions
 - Patron -> Circulation history
 - Patron -> Routing lists
 - Patron -> Statistics
 - Patron -> Fines
   -> Pay

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>
Comment 3 Jonathan Druart 2018-12-17 21:12:04 UTC
Created attachment 83317 [details] [review]
Bug 21965: Update two-column templates with Bootstrap grid: Patrons part 3

This patch modifies several patron templates to use the Bootstrap grid
instead of YUI.

This patch also removes obsolete "text/javascript" attributes from
<script> tags and "text/css" attributes from <style> tags in the
modified templates.

Markup has been corrected in paycollect.tt and readingrec.tt where a
table row lacked <tr>.

To test, apply the patch and view the following pages, confirming that
they look correct at various browser widths:

 - Patron -> Notices
 - Patron -> Purchase suggestions
 - Patron -> Circulation history
 - Patron -> Routing lists
 - Patron -> Statistics
 - Patron -> Fines
   -> Pay

Signed-off-by: Claire Gravely <claire.gravely@bsz-bw.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Owen Leonard 2019-01-04 19:17:14 UTC
*** Bug 21967 has been marked as a duplicate of this bug. ***
Comment 5 Nick Clemens 2019-01-25 20:51:13 UTC
Awesome work all!

Pushed to master for 19.05
Comment 6 Martin Renvoize 2019-01-31 16:58:59 UTC
Enhancement will not be backported to 18.11.x series.