Bug 22022 - Authorised values on the batch item modification page are not displayed in order (order by code, not lib)
Summary: Authorised values on the batch item modification page are not displayed in or...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on: 21635
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-18 18:27 UTC by Nick Clemens
Modified: 2019-01-02 10:43 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bugs 22022: Correct ordering for authorised values (1.29 KB, patch)
2018-12-18 18:34 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 22022: Correct ordering for authorised values (1.33 KB, patch)
2018-12-18 18:53 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22022: Correct ordering for authorised values (1.41 KB, patch)
2018-12-19 18:12 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2018-12-18 18:27:57 UTC
To recreate:
Add a shelving location CODE:ZZZZ lib:"Awake"
Load some items in batch modification
Note the shelving location is misordered
Comment 1 Nick Clemens 2018-12-18 18:34:32 UTC
Created attachment 83371 [details] [review]
Bugs 22022: Correct ordering for authorised values

To test:
1 - Add a shelving location with code "ZZZZ" and lib "Awake"
2 - Load some items in batch modification
3 - Note shelving location dropdown is wrong
4 - Apply patch
5 - Reload page
6 - Note order is correct
Comment 2 Nick Clemens 2018-12-18 18:35:41 UTC
I attached a patch that is a quick fix, however, this should probably be a template plugin to create these dropdown.
Comment 3 Owen Leonard 2018-12-18 18:53:41 UTC
Created attachment 83373 [details] [review]
Bug 22022: Correct ordering for authorised values

To test:
1 - Add a shelving location with code "ZZZZ" and lib "Awake"
2 - Load some items in batch modification
3 - Note shelving location dropdown is wrong
4 - Apply patch
5 - Reload page
6 - Note order is correct

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 Jonathan Druart 2018-12-19 18:12:24 UTC
Created attachment 83399 [details] [review]
Bug 22022: Correct ordering for authorised values

To test:
1 - Add a shelving location with code "ZZZZ" and lib "Awake"
2 - Load some items in batch modification
3 - Note shelving location dropdown is wrong
4 - Apply patch
5 - Reload page
6 - Note order is correct

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Nick Clemens 2018-12-20 00:56:37 UTC
Awesome work all!

Pushed to master for 19.05
Comment 6 Martin Renvoize 2018-12-20 09:58:37 UTC
Pushed to 18.11.x for 18.11.01
Comment 7 Lucas Gass 2018-12-28 22:29:21 UTC
backported to 18.05 for 18.05.08
Comment 8 Fridolin SOMERS 2019-01-02 10:43:27 UTC
Caused by Bug 21635 not in 17.11.x