Bug 22156 - Subscription result list sorts on "checkbox" by default
Summary: Subscription result list sorts on "checkbox" by default
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-17 16:36 UTC by Katrin Fischer
Modified: 2019-05-27 12:27 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 22156: Subscription result list sorts on "checkbox" by default (1.92 KB, patch)
2019-01-17 16:44 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22156: (17.11.x) Subscription result list sorts on "checkbox" by default (1.87 KB, patch)
2019-01-17 16:49 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 22156: Open subs (46.71 KB, image/png)
2019-01-17 21:04 UTC, Ethan
Details
Bug 22156: Closed subs (42.75 KB, image/png)
2019-01-17 21:05 UTC, Ethan
Details
Bug 22156: Subscription result list sorts on "checkbox" by default (2.00 KB, patch)
2019-02-15 20:33 UTC, José-Mario Monteiro-Santos
Details | Diff | Splinter Review
Bug 22156: (17.11.x) Subscription result list sorts on "checkbox" by default (1.95 KB, patch)
2019-02-15 20:38 UTC, José-Mario Monteiro-Santos
Details | Diff | Splinter Review
Bug 22156: Subscription result list sorts on "checkbox" by default (2.06 KB, patch)
2019-02-16 08:57 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 22156: (17.11.x) Subscription result list sorts on "checkbox" by default (2.02 KB, patch)
2019-02-16 09:11 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2019-01-17 16:36:32 UTC
The subscription result list default sort is on the checkbox column (on older version it was ISSN, when that was the first column). Both are a bit confusing to libraries - I think it would make sense to have the default sort on the title.
Comment 1 Owen Leonard 2019-01-17 16:44:21 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2019-01-17 16:49:18 UTC Comment hidden (obsolete)
Comment 3 Ethan 2019-01-17 21:04:41 UTC
Created attachment 84163 [details]
Bug 22156: Open subs
Comment 4 Ethan 2019-01-17 21:05:13 UTC
Created attachment 84164 [details]
Bug 22156: Closed subs
Comment 5 Ethan 2019-01-17 21:09:56 UTC
As seen from the two recently added attachments, it doesn't look like the code is working as intended. The subscriptions on both the open and closed subscriptions tables are not arranged by default by title ascending.
Comment 6 Owen Leonard 2019-01-18 01:01:59 UTC
(In reply to Ethan from comment #5)
> The subscriptions on both the open and closed
> subscriptions tables are not arranged by default by title ascending.

The sorting in the screenshots is correct. When sorting by title we ignore articles like "A" and "The."
Comment 7 José-Mario Monteiro-Santos 2019-02-15 20:33:33 UTC Comment hidden (obsolete)
Comment 8 José-Mario Monteiro-Santos 2019-02-15 20:38:56 UTC Comment hidden (obsolete)
Comment 9 Katrin Fischer 2019-02-16 08:57:45 UTC
Created attachment 85207 [details] [review]
Bug 22156: Subscription result list sorts on "checkbox" by default

This patch adds default sorting by title to the subscription search
results list. Previously no default sort was defined, so it defaulted to
sorting by the first column in the table.

To test, apply the patch and go to Serials.

- Perform a search of subscriptions which will return multiple results.
- Confirm that the table of open subscriptions is sorted by default by
  title ascending.
- Confirm the same for the table of closed subscriptions.

Signed-off-by: Jose-Mario Monteiro-Santos <jose-mario.monteiro-santos@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Katrin Fischer 2019-02-16 09:11:48 UTC
Created attachment 85208 [details] [review]
Bug 22156: (17.11.x) Subscription result list sorts on "checkbox" by default

This patch adds default sorting by title to the subscription search
results list. Previously no default sort was defined, so it defaulted to
sorting by the first column in the table.

To test, apply the patch and go to Serials.

- Perform a search of subscriptions which will return multiple results.
- Confirm that the table of open subscriptions is sorted by default by
  title ascending.
- Confirm the same for the table of closed subscriptions.

Signed-off-by: Jose-Mario Monteiro-Santos <jose-mario.monteiro-santos@inLibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 11 Nick Clemens 2019-02-19 14:02:51 UTC
Awesome work all!

Pushed to master for 19.05
Comment 12 Martin Renvoize 2019-02-25 18:46:10 UTC
Pushed to 18.11.x for 18.11.04
Comment 13 Lucas Gass 2019-03-06 17:16:18 UTC
backported to 18.05.x for 18.05.11