Bug 22412 - Elasticsearch - Second term of a boolean research is lost after applying a facet
Summary: Elasticsearch - Second term of a boolean research is lost after applying a facet
Status: RESOLVED DUPLICATE of bug 22413
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: 18.05
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on: 22413
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-25 19:07 UTC by Marjorie Barry-Vila
Modified: 2019-10-01 14:52 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marjorie Barry-Vila 2019-02-25 19:07:42 UTC
Hi,
There is a problem with facet and advanced research with Elasticsearch.

Test plan:
- Do an advanced research with two term and OR as boolean operator (/opac-search.pl?idx=kw&q=quebec&op=or&idx=kw&q=montreal&op=and&idx=kw&do=Search&sort_by=pubdate_dsc&limit=)
- Have a list of results
- Choose to filter on an item type facet
- a new search is made only on the first searched term (opac-search.pl?q=quebec&sort_by=pubdate_dsc&limit=itype:LIVRE)

Has this problem already been raised?

Regards
Marjorie
Comment 1 Ere Maijala 2019-03-08 10:25:19 UTC
The fix for bug 22413 should also fix this one.
Comment 2 Nick Clemens 2019-10-01 14:52:26 UTC

*** This bug has been marked as a duplicate of bug 22413 ***