Bug 22532 - Remove "random" from Z39.50
Summary: Remove "random" from Z39.50
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Josef Moravec
QA Contact: Marcel de Rooy
URL:
Keywords:
: 12594 (view as bug list)
Depends on: 10462
Blocks: 19220
  Show dependency treegraph
 
Reported: 2019-03-18 15:57 UTC by Josef Moravec
Modified: 2019-04-26 13:56 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.05.00


Attachments
Bug 22532: Remove Z39.50 random (10.97 KB, patch)
2019-03-18 16:49 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22532: Database update (1.94 KB, patch)
2019-03-18 16:50 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 22532: Remove Z39.50 random (11.03 KB, patch)
2019-04-11 23:42 UTC, Hayley Mapley
Details | Diff | Splinter Review
Bug 22532: Database update (2.05 KB, patch)
2019-04-11 23:42 UTC, Hayley Mapley
Details | Diff | Splinter Review
Bug 22532: Remove Z39.50 random (11.02 KB, patch)
2019-04-12 06:01 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 22532: Database update (2.09 KB, patch)
2019-04-12 06:01 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Moravec 2019-03-18 15:57:29 UTC
Bug 10462 removes random parameter from Z39.50 biblio search, but it is still used authority search.
Comment 1 Josef Moravec 2019-03-18 16:49:57 UTC
Created attachment 86724 [details] [review]
Bug 22532: Remove Z39.50 random

Test plan:
Try to search, preview and import authority from Z39.50, everything
should work as expected

Test plan:
Try to search, preview and import authority from Z39.50, everything
should work as expected
Comment 2 Josef Moravec 2019-03-18 16:50:00 UTC
Created attachment 86725 [details] [review]
Bug 22532: Database update
Comment 3 Hayley Mapley 2019-04-11 23:42:25 UTC
Created attachment 87824 [details] [review]
Bug 22532: Remove Z39.50 random

Test plan:
Try to search, preview and import authority from Z39.50, everything
should work as expected

Test plan:
Try to search, preview and import authority from Z39.50, everything
should work as expected

Signed-off-by: Hayley Mapley <hayleymapley@catalyst.net.nz>
Comment 4 Hayley Mapley 2019-04-11 23:42:49 UTC
Created attachment 87825 [details] [review]
Bug 22532: Database update

Signed-off-by: Hayley Mapley <hayleymapley@catalyst.net.nz>

Signed-off-by: Hayley Mapley <hayleymapley@catalyst.net.nz>
Comment 5 Marcel de Rooy 2019-04-12 06:01:43 UTC
Created attachment 87839 [details] [review]
Bug 22532: Remove Z39.50 random

Test plan:
Try to search, preview and import authority from Z39.50, everything
should work as expected

Signed-off-by: Hayley Mapley <hayleymapley@catalyst.net.nz>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 6 Marcel de Rooy 2019-04-12 06:01:48 UTC
Created attachment 87840 [details] [review]
Bug 22532: Database update

Signed-off-by: Hayley Mapley <hayleymapley@catalyst.net.nz>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 7 Marcel de Rooy 2019-04-12 06:03:10 UTC
Thx Josef for making this change. Finally able to close 12594 ;)
Comment 8 Marcel de Rooy 2019-04-12 06:03:49 UTC
*** Bug 12594 has been marked as a duplicate of this bug. ***
Comment 9 Nick Clemens 2019-04-18 12:08:51 UTC
Awesome work all!

Pushed to master for 19.05
Comment 10 Martin Renvoize 2019-04-26 13:56:31 UTC
Enhancement will not be backported to 18.11.x series.