Bug 22546 - MaxFine is not recorded in HEA
Summary: MaxFine is not recorded in HEA
Status: RESOLVED DUPLICATE of bug 23849
Alias: None
Product: Koha
Classification: Unclassified
Component: Websites, Mailing Lists, etc (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Liz Rea
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-20 10:32 UTC by Martin Renvoize
Modified: 2019-10-21 09:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2019-03-20 10:32:24 UTC
I'm not sure how the whitelist of prefs being sent to HEA was constructed and whether there's anything in place to maintain it :(

But, I'd be really interested to see what the usage of the MaxFine preference is in the wild.  The code that implements it is somewhat confusing but it's nature and appears to take into account non-fine amounts which I would not have expected.
Comment 1 Liz Rea 2019-03-21 17:53:13 UTC
Hm, I'm not sure who maintains this whitelist, maybe Paul knows?
Comment 2 Jonathan Druart 2019-03-21 18:18:30 UTC
The list is in C4/UsageStats.pm

There is much more than MaxFine missing, we should add it to the QA/RM check list.
Comment 3 Katrin Fischer 2019-03-21 18:28:50 UTC
I think we might have left it out because it would not be so interesting. With different currencies we get a wide range of amounts there and what would it tell us?
Comment 4 Martin Renvoize 2019-03-21 18:31:06 UTC
It would tell us the important metric of whether it's in use or not 😉. 0 is 0 whatever currency it's in and 0 means 'disabled'.  If there was an overwhelming disablement of it that would mean we could remove it.
Comment 5 Katrin Fischer 2019-03-21 18:32:20 UTC
I know that we use it, if that helps ;)
Comment 6 Martin Renvoize 2019-04-23 15:00:41 UTC
So are you aware that it takes into account not just the Fines but other charges too?
Comment 7 Katrin Fischer 2019-04-23 21:48:49 UTC
Yes, but we are often not clear in our use of terminology around fines and fees I think. The only one you can remove other fines from is noissuescharge, I think. There are several other preferences relating to it. 

Most of those prefs are preset on installation. What would be the best a approach to update the list for HEA and get meaningful data?
Comment 8 Jonathan Druart 2019-10-21 09:03:58 UTC

*** This bug has been marked as a duplicate of bug 23849 ***