Bug 22556 - Add ability to quickly filter funds/budgets by library on the Acquisitions home page
Summary: Add ability to quickly filter funds/budgets by library on the Acquisitions ho...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
: 20574 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-21 10:40 UTC by Kyle M Hall
Modified: 2019-05-30 11:17 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
This enhancement adds a "Filter by library" pulldown list to the budgets table on the acquisitions home page.
Version(s) released in:
19.05.00


Attachments
Bug 22556: Add ability to quickly filter funds/budgets by library on the Acquisitions home page (2.41 KB, patch)
2019-03-21 10:45 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 22556: Add ability to quickly filter funds/budgets by library on the Acquisitions home page (2.44 KB, patch)
2019-03-21 15:00 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 22556: Add ability to quickly filter funds/budgets by library on the Acquisitions home page (2.48 KB, patch)
2019-03-22 19:42 UTC, Bin Wen
Details | Diff | Splinter Review
Bug 22556: Add ability to quickly filter funds/budgets by library on the Acquisitions home page (2.54 KB, patch)
2019-04-08 23:04 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2019-03-21 10:40:44 UTC
Some librarians would like to have a quick pulldown selector to filter budgets and funds by library on the acquisitions home page.
Comment 1 Kyle M Hall 2019-03-21 10:41:12 UTC
*** Bug 20574 has been marked as a duplicate of this bug. ***
Comment 2 Kyle M Hall 2019-03-21 10:45:50 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2019-03-21 15:00:49 UTC Comment hidden (obsolete)
Comment 4 José-Mario Monteiro-Santos 2019-03-22 18:31:08 UTC
If a sub-fund assigned to a specific library is collapsed, it is not shown in the results when the table is filtered. I can understand if this is an acceptable behavior, but personally I expected all related funds to be shown when filtering by library. 

In a similar fashion, if a "main" fund is assigned to a library but its sub-funds are not, the main fund has the collapse/expand arrow even though there is nothing else to show. (I'm not sure how often that would happen in real production servers though)
Comment 5 Bin Wen 2019-03-22 19:42:30 UTC Comment hidden (obsolete)
Comment 6 Bin Wen 2019-03-22 19:59:19 UTC
It is ok to follow the test plan, I saw José-Mario's comment and added sub-fund to main fund. It is true that sub-fund is not shown after filtering, which is indeed a problem in my opinion.
Comment 7 Katrin Fischer 2019-04-08 23:04:25 UTC
Created attachment 87567 [details] [review]
Bug 22556: Add ability to quickly filter funds/budgets by library on the Acquisitions home page

Some librarians would like to have a quick pulldown selector to filter budgets and funds by library on the acquisitions home page.

Test Plan:
1) Apply this patch
2) Navigate to the Acquisitions home page
3) Notice the new pulldown on the budgets table labeled "Filter by library"
4) Select a library that has one or more budgets/funds
5) Note only budgets/funds from that library now display!

Signed-off-by: Liz Rea <wizzyrea@gmail.com>
Signed-off-by: Bin Wen <bin.wen@inlibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Nick Clemens 2019-04-25 11:56:59 UTC
Awesome work all!

Pushed to master for 19.05
Comment 9 Martin Renvoize 2019-04-26 15:32:53 UTC
Enhancement will not be backported to 18.11.x series.