Bug 23026 - Staff client CAS URL escaped twice, preventing login
Summary: Staff client CAS URL escaped twice, preventing login
Status: RESOLVED DUPLICATE of bug 22585
Alias: None
Product: Koha
Classification: Unclassified
Component: Authentication (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-31 16:35 UTC by Nick Clemens
Modified: 2019-05-31 17:51 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 23026: Do not double encode CAS url (1.45 KB, patch)
2019-05-31 16:38 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2019-05-31 16:35:19 UTC
Bug 21973 fixed CAS login for the opac - we need to do the same for the staff client
Comment 1 Nick Clemens 2019-05-31 16:38:01 UTC
Created attachment 90235 [details] [review]
Bug 23026: Do not double encode CAS url

It is already escaped correctly in
C4::Auth_with_cas::_url_with_get_params using URI::Escape::uri_escape

Note that shibbolethLoginUrl is not and must be url escaped in template
("be consistent, they said")
Comment 2 Jonathan Druart 2019-05-31 17:51:56 UTC

*** This bug has been marked as a duplicate of bug 22585 ***