Bug 23031 - Restore 'Add to basket' as immediately accessible option on vendor search page
Summary: Restore 'Add to basket' as immediately accessible option on vendor search page
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords: Manual
Depends on: 21364
Blocks: 24569
  Show dependency treegraph
 
Reported: 2019-06-02 08:38 UTC by Katrin Fischer
Modified: 2020-05-18 13:14 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
20.05.00


Attachments
Bug 23031: Make 'add to basket' accessible in one click (fix regression) (4.20 KB, patch)
2020-01-13 11:07 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 23031: Make 'add to basket' accessible in one click (fix regression) (4.25 KB, patch)
2020-01-15 18:55 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 23031: Make 'add to basket' accessible in one click (fix regression) (4.30 KB, patch)
2020-01-29 21:54 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2019-06-02 08:38:30 UTC
When the change for bug 21364 was made, there as some discussion about what buttons should be accessible immediately and what should be hidden in the menu. 

Owen's last suggestion was:

The "View" part of the split button is an unnecessary duplication of the linked basket name earlier in the table. I think the actions column should have two possible buttons: "Add to basket" and "Close basket."

Maybe we could implement this? As I understand it, we would remove the view part which would leave us with 2 (or 3: uncertain prices instead of close basket) buttons that show outside of a menu.
Comment 1 Owen Leonard 2019-06-04 16:51:34 UTC
Would it make sense to have the actions menu include the same options the basket view toolbar has?

 - Add to basket
 - Edit basket
 - Delete basket
 - Close basket
 - Export as CSV
 - Create EDIFACT order
 - E-mail order
Comment 2 Katrin Fischer 2019-06-17 20:52:15 UTC
(In reply to Owen Leonard from comment #1)
> Would it make sense to have the actions menu include the same options the
> basket view toolbar has?
> 
>  - Add to basket
>  - Edit basket
>  - Delete basket
>  - Close basket
>  - Export as CSV
>  - Create EDIFACT order
>  - E-mail order

I think the more urgent issue here is to make the 'add to basket' more prominent again. But I see no reason not to include them, other than the list might get a little full :)
Comment 3 Jonathan Druart 2020-01-13 11:07:32 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2020-01-15 18:55:43 UTC
Created attachment 97409 [details] [review]
Bug 23031: Make 'add to basket' accessible in one click (fix regression)

Since bug 21364 we have 'view' then 'add to basket' that is accessible
in 2 clicks. We should have it directly accessible.

Test plan:
Create a new basket
Add a new order to the basket (note that the link is directly
accessible)
When a new order is added you can close the basket from the basket list
view
Note that the dropdown button displays correctly

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Katrin Fischer 2020-01-29 21:51:36 UTC
If I understand this correctly, the 'view' is on the basket name link and the 'add to order' is default action on the button?
Comment 6 Katrin Fischer 2020-01-29 21:54:48 UTC
Created attachment 98093 [details] [review]
Bug 23031: Make 'add to basket' accessible in one click (fix regression)

Since bug 21364 we have 'view' then 'add to basket' that is accessible
in 2 clicks. We should have it directly accessible.

Test plan:
Create a new basket
Add a new order to the basket (note that the link is directly
accessible)
When a new order is added you can close the basket from the basket list
view
Note that the dropdown button displays correctly

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Jonathan Druart 2020-01-30 09:24:41 UTC
(In reply to Katrin Fischer from comment #5)
> If I understand this correctly, the 'view' is on the basket name link and
> the 'add to order' is default action on the button?

Yes, from comment 0:
"""
The "View" part of the split button is an unnecessary duplication of the linked basket name earlier in the table
"""
Comment 8 Katrin Fischer 2020-01-30 10:43:46 UTC
(In reply to Jonathan Druart from comment #7)
> (In reply to Katrin Fischer from comment #5)
> > If I understand this correctly, the 'view' is on the basket name link and
> > the 'add to order' is default action on the button?
> 
> Yes, from comment 0:
> """
> The "View" part of the split button is an unnecessary duplication of the
> linked basket name earlier in the table
> """

All good then :)
Comment 9 Martin Renvoize 2020-01-30 11:03:52 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 10 Joy Nelson 2020-02-10 23:21:28 UTC
Enhancement not backported to 19.11.x