Bug 23190 - Authority hierarchy display appears to be broken
Summary: Authority hierarchy display appears to be broken
Status: RESOLVED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 8523
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-24 09:24 UTC by Katrin Fischer
Modified: 2022-08-08 15:56 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Three authorities to test (11.16 KB, text/plain)
2022-08-08 15:28 UTC, Caroline Cyr La Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2019-06-24 09:24:39 UTC
We followed the instructions on bug 8523 comment 19, but we didn't manage to get a tree view:

AuthDisplayHieararchy ON

Example:
151 $aGermany
  551 $a Baden-Württemberg $w h

151 $aBaden-Württemberg
  551 $a Konstanz $w h
  551 $a Germany $w g

151 $aKonstanz
  551 $a Baden-Württemberg $w g
  551 $a Fürstenberg $w h
  551 $a Paradies $w h

151 $a Fürstenberg
  551 $a Konstanz $w g

151 $a Paradies
  551 $a Konstanz $w g

The authority that is displayed shows as the only entry of the 'tree' abvove the record in staff and OPAC. Links have been cataloged in both directions.

Screenshots from Owen on bug 21128 from 2018 suggest that the feature still worked at this time.
Comment 1 Frédéric Demians 2019-07-03 05:11:43 UTC
Do you have sample data?
Comment 2 Katrin Fischer 2019-07-05 06:15:14 UTC
No real data, just what is written up in the first comment basically, manually created test records.
Comment 3 Marcel de Rooy 2020-01-21 08:59:10 UTC
The feature needs an authid in $9.
The editor in authorities does not (or no longer) enforce the use of the connected authority plugin (for some reason). Allowing you to enter a name manually but if you do that, you won't have the link in $9 (and the tree cannot be built).
In master the icon of the authority plugin [three dots] has been moved. Very hard to see too. They are on the same line as the a for subfield and the field label Geographic name.

I would say: The feature is not broken, but the authority editor needs some attention at least.
Comment 4 Katrin Fischer 2020-01-21 09:10:28 UTC
Thx Marcel, I will try to give it another go.
Comment 5 Caroline Cyr La Rose 2022-08-08 15:28:01 UTC
Created attachment 138837 [details]
Three authorities to test
Comment 6 Caroline Cyr La Rose 2022-08-08 15:50:36 UTC
I tried this 

1. Set AuthDisplayHierarchy to Show
2. Upload the attached records
   2.1. Go to Tools > Stage MARC records for import
   2.2. Click browse and choose the attached file
   2.3. Click Upload file
   2.4. In Record type, choose Authority
   2.5. Click Stage for import
   2.6. Click Managed staged records
   2.7. Click Import this batch into the catalog
3. Edit each record and enter the correct authid in 551$9
   3.1. Click on 'Edit' for each record
   3.2. Go to field 551 and expand it to show $9 (it should already have my own, but they won't be accurate anymore)
   3.3. Enter the correct authid in each 551$9 where there is a $w

Example, if Germany is authid 1, Baden-Württemberg is authid 2 and Konstanz is authid 3,

001 1
151 $a Germany
551 $w h
    $a Baden-Württemberg (Germany)
    $9 2

001 2
151 $a Baden-Württemberg (Germany)
551 $w g
    $a Germany
    $9 1
551 $w h
    $a Konstanz (Germany)
    $9 3

001 3
151 $a Konstanz (Germany)
551 $w g
    $a Baden-Württemberg (Germany)
    $9 2

The trees should appear at the top of the records in both staff and OPAC. I tried this on 22.05.03 and master (22.06).

I'm adding more information about this in the manual as part as documentation for Bug 27519.