Bug 23730 - Exporting reports is broken
Summary: Exporting reports is broken
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
: 23759 (view as bug list)
Depends on: 23390
Blocks:
  Show dependency treegraph
 
Reported: 2019-10-03 13:21 UTC by Nick Clemens
Modified: 2019-11-08 14:27 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.11.00


Attachments
Bug 23730: Fix export of reports (1.02 KB, patch)
2019-10-03 13:22 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 23730: Fix export of reports (1.08 KB, patch)
2019-10-03 13:36 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2019-10-03 13:21:29 UTC
bug 23390 changed the return values of get_prepped_report, I missed a call though
Comment 1 Nick Clemens 2019-10-03 13:22:54 UTC
Created attachment 93596 [details] [review]
Bug 23730: Fix export of reports

To test:
1 - Run a saved report
2 - Attempt to export results
3 - It fails
4 - Apply patch
5 - It succeeds
Comment 2 Katrin Fischer 2019-10-03 13:36:58 UTC
Created attachment 93600 [details] [review]
Bug 23730: Fix export of reports

To test:
1 - Run a saved report
2 - Attempt to export results
3 - It fails
4 - Apply patch
5 - It succeeds

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 3 Katrin Fischer 2019-10-07 07:56:08 UTC
*** Bug 23759 has been marked as a duplicate of this bug. ***
Comment 4 Martin Renvoize 2019-10-07 11:58:42 UTC
Nice work!

Pushed to master for 19.11.00
Comment 5 Fridolin SOMERS 2019-11-08 14:27:08 UTC
Depends on bug 23390 not in 19.05.x