Bug 2399 - All status fields in the item edit interface offer two blank/null entries per dropdown instead of one
Summary: All status fields in the item edit interface offer two blank/null entries per...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.6
Hardware: PC All
: P3 normal (vote)
Assignee: Katrin Fischer
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-24 10:30 UTC by Chris Cormack
Modified: 2013-12-05 19:59 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 2399: All status fields in the item edit interface offer two blank/null entries per dropdown instead of one (24.17 KB, patch)
2012-04-02 17:31 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 2399: Follow up removing MySQLisms from ru-RU and uk-UA sample files (4.67 KB, patch)
2012-04-03 18:24 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 2399: All status fields in the item edit interface offer two blank/null entries per dropdown instead of one (24.22 KB, patch)
2012-04-08 08:56 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 2399: Follow up removing MySQLisms from ru-RU and uk-UA sample files (4.73 KB, patch)
2012-04-08 08:57 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:50:45 UTC


---- Reported by debra.denault@liblime.com 2008-07-24 10:30:36 ----

All status fields in the item edit interface in the lastest versions of 3.0 offer two blank/null entries per dropdown. One I believe is from the entry in their authorized values list of 0 which typically has a blank description and the other is likely from the default null field added in the interface to dropdown lists. If the values of 0 in the status fields purpose is to act like a "null" then the other default interface null should be removed. If not, then the 0 values in each of the status categories should be given a description so that they do not show as blank in the dropdown lists.



---- Additional Comments From paul.poulain@biblibre.com 2008-08-04 07:02:56 ----

hint : in MARC editor, if a value is not mandatory, then the list builded automatically contains the empty/null line. If you add it explicitely, then you'll get 2. Maybe your problem is related to that ?



---- Additional Comments From chris.nighswonger@liblime.com 2008-08-06 10:33:41 ----

There appear to be more fundamental issues underlying this problem. Moving this forward to be fixed in 3.2



---- Additional Comments From nengard@gmail.com 2009-12-23 17:59:16 ----

This bug hasn't been touched in nearly a year, please revisit and test and close if appropriate.



---- Additional Comments From oleonard@myacpl.org 2009-12-28 14:35:20 ----

I still see this problem in HEAD



---- Additional Comments From nengard@gmail.com 2010-05-04 15:21:53 ----

Just bumping this up since I see this issue in 3.2 Alpha2



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:50 UTC  ---

This bug was previously known as _bug_ 2399 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2399

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was debra.denault@liblime.com.
CC member rch@liblime.com does not have an account here

Comment 1 Katrin Fischer 2011-04-25 09:29:58 UTC
This bug hasn't been touched in nearly another year, please revisit and test and
close if appropriate.
Comment 2 Nicole C. Engard 2011-04-25 14:13:41 UTC
For subfields 4, 5, and 7 of the item record this is still an issue in 3.4.
Comment 3 Katrin Fischer 2012-04-02 06:39:31 UTC
Updating version to master, 5 and 7 still have 2 empty lines theres
For 3.6 it's 4,5 and 7.

I think the problem is caused by the sample data for authorized values. 
Perhaps the line for 0 without description should be removed from all the sample data? But I am not sure if it's safe to do this?
Comment 4 Katrin Fischer 2012-04-02 17:31:49 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2012-04-03 18:24:29 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2012-04-06 12:30:20 UTC
(In reply to comment #4)
Perhaps a better way to do this is to remove this empty entry in template files ?
Just for discussion.
Comment 7 Jonathan Druart 2012-04-06 12:31:09 UTC
(In reply to comment #5)
> Created attachment 8828 [details] [review]
> Bug 2399: Follow up removing MySQLisms from ru-RU and uk-UA sample files

This patch does not remove all the MYSQLism, LAST_INSERT_ID is a MYSQLism :-/
Comment 8 Katrin Fischer 2012-04-06 12:51:32 UTC
Hi Jonathan, I only touched those lines and removed the '' because I had to renumber them to keep the current functionality. Can we please take a note of that mysqlism and remove it another time?

I think the empty lines have been introduced a longer time ago and people have adjusted to them modifying their authorized values. Removing the empty lines now will cause a lot of trouble, removing those lines without descriptions from the sample files will hurt no existing installations.

Also I think it's much nicer to make Koha put in an empty line than to expect people insert those into the authorized values.
Comment 9 Chris Cormack 2012-04-08 08:56:17 UTC
Created attachment 9006 [details] [review]
Bug 2399: All status fields in the item edit interface offer two blank/null entries per dropdown instead of one

Removes the '0' values without description from the sample date for
authorised values.

To test:
1) Verify that SQL files load correctly
- truncate authorised_values; /* empty authorised values table */
- load sample data using one of the SQL files
2) Check cataloging interface - all status fields should only show 1 empty line

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 10 Chris Cormack 2012-04-08 08:57:07 UTC
Created attachment 9007 [details] [review]
Bug 2399: Follow up removing MySQLisms from ru-RU and uk-UA sample files

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 11 Jonathan Druart 2012-05-03 15:04:50 UTC
QA Comment:

First patch delete the empty line for authorised values and remove backquotes.
Second patch remove backquotes from ru-RU and uk-UA files.

Marked as Passed QA
Comment 12 Jared Camins-Esakov 2012-06-14 11:49:18 UTC
This patch will be in 3.6.6.