Bug 24167 - We should support installation on Debian 10 [OMNIBUS]
Summary: We should support installation on Debian 10 [OMNIBUS]
Status: NEW
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 17084 22522 24552 25481 25482 14759 23799 24639 25591 25633
Blocks:
  Show dependency treegraph
 
Reported: 2019-12-04 10:15 UTC by Martin Renvoize
Modified: 2020-06-02 01:35 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2019-12-04 10:15:10 UTC
Debian 10 has been stable for a little while now, and Debian 8 is nearing end of life.

We really should be supporting Debian 10 now.
Comment 1 Magnus Enger 2020-01-22 11:31:56 UTC
What are the known problems? Just the one in bug 23799?
Comment 2 Martin Renvoize 2020-01-22 13:15:41 UTC
I think this bug is meant to serve as a collector.. right now the packaging is the biggest issue and Mason has been working on that for us..

Once we have packages that build at all, we can run the test suit against it more thorough and find other possible issues..

I'm envisaging a few DB issues as newer Debian comes with newer MariaDB and perhaps some other dependency problems.