Bug 24216 - kohastructure.sql uses BOOLEANs
Summary: kohastructure.sql uses BOOLEANs
Status: RESOLVED DUPLICATE of bug 21294
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-11 11:48 UTC by paxed
Modified: 2019-12-17 10:42 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2019-12-11 11:48:56 UTC
kohastructure.sql uses both BOOLEAN and tinyint(1) for boolean values. The existing booleans should be converted to tinyints, as per the coding guidelines https://wiki.koha-community.org/wiki/Coding_Guidelines#SQL12:_Booleans
Comment 1 Jonathan Druart 2019-12-17 10:42:42 UTC

*** This bug has been marked as a duplicate of bug 21294 ***