Bug 24382 - Wrong information showing on detail pages for fines/fees and payments
Summary: Wrong information showing on detail pages for fines/fees and payments
Status: RESOLVED DUPLICATE of bug 22435
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 14825
  Show dependency treegraph
 
Reported: 2020-01-08 21:49 UTC by Katrin Fischer
Modified: 2021-11-10 10:28 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2020-01-08 21:49:36 UTC
At the moment, the _first_ table in a payment details page reads:

Details of payment
Date 	Description of charges 	Barcode 	Due date 	Return date 	Note 	Amount 	Outstanding

This makes no sense - these are the columns for a fine or fee, but they don't apply well to a payment.

When you compare to the table shown for a fine/fee, I think the table should actually display with these lines:

Date created 	Date updated 	Amount 	Amount outstanding 	Type 	Note 	Transacting librarian 	Date/time of change 	Amount of change 	Type of change
Comment 1 Martin Renvoize 2021-11-10 10:28:32 UTC
Bug 22435 considerably improved the clarity of the details page.. I think we can mark this one as resolved.
Comment 2 Martin Renvoize 2021-11-10 10:28:40 UTC

*** This bug has been marked as a duplicate of bug 22435 ***