Bug 24569 - Cannot add to basket if it is the only action
Summary: Cannot add to basket if it is the only action
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 23031
Blocks:
  Show dependency treegraph
 
Reported: 2020-02-03 18:47 UTC by Nick Clemens
Modified: 2020-02-11 00:07 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
20.05.00


Attachments
Bug 24569: (bug 23031 follow-up) Fix "add to basket" link (4.28 KB, patch)
2020-02-04 09:45 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 24569: (bug 23031 follow-up) Fix "add to basket" link (4.34 KB, patch)
2020-02-04 09:53 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 24569: (bug 23031 follow-up) Fix "add to basket" link (4.40 KB, patch)
2020-02-04 12:37 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 24569: (QA follow-up) Fix closing <a> tag (1.45 KB, patch)
2020-02-04 12:37 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2020-02-03 18:47:36 UTC
When "Add to basket" is the only action the modal is not created so one cannot add to the basket from booksellers.pl

Regression caused by Bug 23031
Comment 1 Jonathan Druart 2020-02-04 09:45:38 UTC
Created attachment 98367 [details] [review]
Bug 24569: (bug 23031 follow-up) Fix "add to basket" link

The modal needs to be defined in both cases.
Comment 2 Jonathan Druart 2020-02-04 09:53:28 UTC
Created attachment 98369 [details] [review]
Bug 24569: (bug 23031 follow-up) Fix "add to basket" link

The modal needs to be defined in both cases.

Test plan:
Repeat test plan from bug 23031 and click on the buttons!
Comment 3 Nick Clemens 2020-02-04 12:37:52 UTC
Created attachment 98384 [details] [review]
Bug 24569: (bug 23031 follow-up) Fix "add to basket" link

The modal needs to be defined in both cases.

Test plan:
Repeat test plan from bug 23031 and click on the buttons!

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 4 Nick Clemens 2020-02-04 12:37:55 UTC
Created attachment 98385 [details] [review]
Bug 24569: (QA follow-up) Fix closing <a> tag

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Nick Clemens 2020-02-04 12:38:11 UTC
Small fix, passing QA
Comment 6 Martin Renvoize 2020-02-04 13:39:19 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 7 Joy Nelson 2020-02-11 00:07:03 UTC
dependencies missing in 19.11.x  Not backported