Bug 24766 - Provide an option to show news blocks for all available languages
Summary: Provide an option to show news blocks for all available languages
Status: RESOLVED DUPLICATE of bug 24387
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 22318 27451
Blocks: 27459
  Show dependency treegraph
 
Reported: 2020-02-29 08:59 UTC by Katrin Fischer
Modified: 2021-07-12 08:29 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2020-02-29 08:59:05 UTC
With the move of the HTML system preferences to the news tool, adding a logo to the OPAC will require that you add a news block for it to each installed language. If you add languages later on, you will always need to test and remember. This adds quite a bit of extra maintenance as there appears to be no fallback option.

It would be nice if we could define that something should show for 'all languages' or as a 'fallback' if there is no other content for the language defined.
Comment 1 Owen Leonard 2020-05-01 17:17:32 UTC
Another option might be a "Copy to other languages" option.
Comment 2 Martin Renvoize 2020-05-04 10:21:17 UTC
Having now dug through the code a little.. I must admit the News system feels really weird
Comment 3 Jonathan Druart 2021-07-12 08:29:11 UTC
Done on bug 24387.

*** This bug has been marked as a duplicate of bug 24387 ***