Bug 25038 - OPAC reading history checkouts and on-site tabs not working
Summary: OPAC reading history checkouts and on-site tabs not working
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Keywords:
Depends on: 14862
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-02 07:44 UTC by Lari Taskula
Modified: 2020-05-13 21:42 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
20.05.00, 19.11.06


Attachments
Bug 25038: Fix tabs on the OPAC reading history view (2.56 KB, patch)
2020-04-07 11:26 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 25038: Fix tabs on the OPAC reading history view (2.62 KB, patch)
2020-04-07 11:36 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 25038: Fix tabs on the OPAC reading history view (2.72 KB, patch)
2020-04-10 10:18 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 25038: Fix tabs on the OPAC reading history view (2.72 KB, patch)
2020-04-11 20:42 UTC, Lari Taskula
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lari Taskula 2020-04-02 07:44:16 UTC
OPAC reading history table has three tabs for different checkout types: All, Checkouts, On-site checkouts.

However, all of your checkouts are visible every tab regardless of checkout type.

To reproduce:
1. Enable OnSiteCheckouts system preference
2. Perform two checkouts: one normal checkout, one on-site checkout
3. Go to OPAC /cgi-bin/koha/opac-readingrecord.pl
4. Observe your checkouts all are visible in every tab (All, Checkouts, On-site checkouts)
Comment 1 Lari Taskula 2020-04-03 09:03:20 UTC
Unfortunately I can't work on this but if anyone wants to fix it, feel free!
Comment 2 Jonathan Druart 2020-04-07 11:25:03 UTC
Certainly caused by
  commit 8b1fb387acee35ba64f61d59fd332a79d5759e06
  Bug 14862: Upgrade jQuery from 1.7 to 3.4.1 in OPAC
Comment 3 Jonathan Druart 2020-04-07 11:26:36 UTC
Created attachment 102508 [details] [review]
Bug 25038: Fix tabs on the OPAC reading history view

OPAC reading history table has three tabs for different checkout types: All, Checkouts, On-site checkouts.

However, all of your checkouts are visible every tab regardless of checkout type.

Test plan:
1. Enable OnSiteCheckouts system preference
2. Perform two checkouts: one normal checkout, one on-site checkout
3. Go to OPAC /cgi-bin/koha/opac-readingrecord.pl
4. Observe your checkouts all are visible in first tab
5. Select second tab and notice that the table is now filtered
6. Same with third tab
Comment 4 Owen Leonard 2020-04-07 11:36:46 UTC
Created attachment 102509 [details] [review]
Bug 25038: Fix tabs on the OPAC reading history view

OPAC reading history table has three tabs for different checkout types: All, Checkouts, On-site checkouts.

However, all of your checkouts are visible every tab regardless of checkout type.

Test plan:
1. Enable OnSiteCheckouts system preference
2. Perform two checkouts: one normal checkout, one on-site checkout
3. Go to OPAC /cgi-bin/koha/opac-readingrecord.pl
4. Observe your checkouts all are visible in first tab
5. Select second tab and notice that the table is now filtered
6. Same with third tab

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Marcel de Rooy 2020-04-10 10:18:52 UTC
Created attachment 102693 [details] [review]
Bug 25038: Fix tabs on the OPAC reading history view

OPAC reading history table has three tabs for different checkout types: All, Checkouts, On-site checkouts.

However, all of your checkouts are visible every tab regardless of checkout type.

Test plan:
1. Enable OnSiteCheckouts system preference
2. Perform two checkouts: one normal checkout, one on-site checkout
3. Go to OPAC /cgi-bin/koha/opac-readingrecord.pl
4. Observe your checkouts all are visible in first tab
5. Select second tab and notice that the table is now filtered
6. Same with third tab

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 6 Lari Taskula 2020-04-11 20:42:21 UTC
Created attachment 102770 [details] [review]
Bug 25038: Fix tabs on the OPAC reading history view

OPAC reading history table has three tabs for different checkout types: All, Checkouts, On-site checkouts.

However, all of your checkouts are visible every tab regardless of checkout type.

Test plan:
1. Enable OnSiteCheckouts system preference
2. Perform two checkouts: one normal checkout, one on-site checkout
3. Go to OPAC /cgi-bin/koha/opac-readingrecord.pl
4. Observe your checkouts all are visible in first tab
5. Select second tab and notice that the table is now filtered
6. Same with third tab

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Lari Taskula <lari.taskula@hypernova.fi>
Comment 7 Martin Renvoize 2020-04-14 07:37:21 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 8 Joy Nelson 2020-05-04 21:40:24 UTC
backported to 19.11.x for 19.11.06
Comment 9 Lucas Gass 2020-05-13 21:42:22 UTC
missing dependencies for 19.05.x, no backport