Bug 25492 - Your Account Menu button does nothing on mobile devices
Summary: Your Account Menu button does nothing on mobile devices
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 25830 25831 (view as bug list)
Depends on: 18084
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-13 20:12 UTC by John Yorio
Modified: 2020-11-30 21:52 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.01, 19.11.07, 19.05.12


Attachments
Bug 25492: Your Account Menu button does nothing on mobile devices (1.79 KB, patch)
2020-05-23 14:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 25492: Your Account Menu button does nothing on mobile devices (1.84 KB, patch)
2020-05-26 12:06 UTC, David Nind
Details | Diff | Splinter Review
Bug 25492: Your Account Menu button does nothing on mobile devices (1.90 KB, patch)
2020-05-28 22:52 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description John Yorio 2020-05-13 20:12:08 UTC
Replicated with Koha 19.11.04 and 19.11.05

Steps to reproduce:

1) Bring up the OPAC on a mobile device with a smaller screen (e.g. cell phone) or using an emulator
2) Log into an account
3) Find the button labeled "Your account menu"
4) Click it. 
5) Nothing happens.

******
I didn't see any errors in the browser console or in the Koha logs.

I tested this with 18.11.05 and clicking the button expands the menu as you'd expect.
Comment 1 Owen Leonard 2020-05-20 18:39:45 UTC
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[fed5158d66abafbe482a3625fa010c160c82a529] Bug 18084: Language selector hidden in user menu on mobile interfaces
Comment 2 Owen Leonard 2020-05-23 14:45:12 UTC
Created attachment 105302 [details] [review]
Bug 25492: Your Account Menu button does nothing on mobile devices

This patch removes some redundant code from the OPAC JavaScript which
was causing problems with the show/hide action on two controls which are
shown only at narrower browser widths: The "Your account" menu shown
when the user is on a user-related page, and the "Refine your search"
menu shown on the search results page.

To test, apply the patch and go to the OPAC. Narrow your browser width
to below 768 pixels.

 - Perform a search.
 - On the search results page you should see a "Refine your search"
   link at the top of the results. Clicking it should expand and
   collapse the facets menu.
 - Log in to the OPAC.
 - On the "Your summary" page there should be a "Your account menu" link
   at the top of the main part of the page. Clicking it should expand
   and collapse the account menu.
 - Verify that these menus display correctly when you widen and narrow
   the browser window.
Comment 3 David Nind 2020-05-26 12:06:43 UTC
Created attachment 105358 [details] [review]
Bug 25492: Your Account Menu button does nothing on mobile devices

This patch removes some redundant code from the OPAC JavaScript which
was causing problems with the show/hide action on two controls which are
shown only at narrower browser widths: The "Your account" menu shown
when the user is on a user-related page, and the "Refine your search"
menu shown on the search results page.

To test, apply the patch and go to the OPAC. Narrow your browser width
to below 768 pixels.

 - Perform a search.
 - On the search results page you should see a "Refine your search"
   link at the top of the results. Clicking it should expand and
   collapse the facets menu.
 - Log in to the OPAC.
 - On the "Your summary" page there should be a "Your account menu" link
   at the top of the main part of the page. Clicking it should expand
   and collapse the account menu.
 - Verify that these menus display correctly when you widen and narrow
   the browser window.

Signed-off-by: David Nind <david@davidnind.com>
Comment 4 Katrin Fischer 2020-05-28 22:52:22 UTC
Created attachment 105427 [details] [review]
Bug 25492: Your Account Menu button does nothing on mobile devices

This patch removes some redundant code from the OPAC JavaScript which
was causing problems with the show/hide action on two controls which are
shown only at narrower browser widths: The "Your account" menu shown
when the user is on a user-related page, and the "Refine your search"
menu shown on the search results page.

To test, apply the patch and go to the OPAC. Narrow your browser width
to below 768 pixels.

 - Perform a search.
 - On the search results page you should see a "Refine your search"
   link at the top of the results. Clicking it should expand and
   collapse the facets menu.
 - Log in to the OPAC.
 - On the "Your summary" page there should be a "Your account menu" link
   at the top of the main part of the page. Clicking it should expand
   and collapse the account menu.
 - Verify that these menus display correctly when you widen and narrow
   the browser window.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Jonathan Druart 2020-06-12 12:17:32 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 6 Aleisha Amohia 2020-06-18 05:55:00 UTC
backported to 20.05.x for 20.05.01
Comment 7 Aleisha Amohia 2020-06-18 05:55:14 UTC
backported to 19.11.x for 19.11.07
Comment 8 Victor Grousset/tuxayo 2020-06-19 03:50:55 UTC
Backported to 19.05.x branch for 19.05.12
Comment 9 Owen Leonard 2020-06-20 21:47:39 UTC
*** Bug 25830 has been marked as a duplicate of this bug. ***
Comment 10 Owen Leonard 2020-06-22 12:45:51 UTC
*** Bug 25831 has been marked as a duplicate of this bug. ***