Bug 25518 - Claims returned to offer a 'checkin' option
Summary: Claims returned to offer a 'checkin' option
Status: RESOLVED DUPLICATE of bug 25552
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-15 16:26 UTC by Fiona Borthwick
Modified: 2020-05-22 22:55 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fiona Borthwick 2020-05-15 16:26:58 UTC
The new Claims Returned functionality is great but it is not ideal that the item remains on the patron's account and counts towards their checkout limit.

It is debatable that this is correct behaviour whilst it is 'pending' but if the claims returned is then marked as resolved, it would be nice if the item was 'checked in' at the same time.

In the majority of cases, the case would be resolved as the item would be found by the patron or in the library. Yes the process of marking the claim resolved, could be followed up with a manual checkin but it would be good if this was automatic.

I would also argue that some libraries may want to remove the item from the patron's checkouts lists as soon as it is marked claims returned. I can see that there may be some angry patrons who insist they have returned it (which is why it has been marked claims returned) and therefore do not want to see it visible in their list of checkouts and affecting their limit.

Perhaps the ClaimReturnedChargeFee system preference could be enhanced to add a further two options?
1) remove the checkout from the patron's record when it has been marked claims returned
2) checkin the item automatically when claims returned is resolved

Or have a new preference to deal with this situation specifically?
Comment 1 Fiona Borthwick 2020-05-15 16:28:43 UTC
Or use the MarkLostItemsAsReturned system preference to add these extra options?
Comment 2 Katrin Fischer 2020-05-22 22:53:29 UTC
Hi Fiona, I tested another bug earlier today that I think does, what you want. Marking duplicate - please check and undo if I am wrong.

*** This bug has been marked as a duplicate of bug 25583 ***
Comment 3 Katrin Fischer 2020-05-22 22:55:21 UTC

*** This bug has been marked as a duplicate of bug 25552 ***