Bug 25557 - Column config table in acquisitions order does not match the acq table in baskets
Summary: Column config table in acquisitions order does not match the acq table in bas...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Lucas Gass
QA Contact: Testopia
URL:
Keywords:
: 25714 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-20 18:52 UTC by Kelly McElligott
Modified: 2020-11-30 21:52 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.01, 19.11.07, 19.05.12


Attachments
Bug 25557: Correct basket.pl column config (1.48 KB, patch)
2020-05-21 23:47 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 25557: Correct basket.pl column config (1.50 KB, patch)
2020-05-28 16:06 UTC, Victor Grousset/tuxayo
Details | Diff | Splinter Review
k (1.54 KB, patch)
2020-05-28 21:32 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 25557: Correct basket.pl column config (1.59 KB, patch)
2020-05-28 21:33 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kelly McElligott 2020-05-20 18:52:25 UTC
The actual way that the Acq table appears in the basket view (basket.pl), 

1.Basket #
2. Order information
3. RRP Tax Exc
4. Actual Cost Exc
5. Budgeted Cost Tax Exc
6. RRP Tax Included
7. Actual Cost Tax Inc
8. Budgeted Cost Tax Inc
9. Replacement Price
10. Quantity

But in the column config table

1.Basket #
2. Order Info
3. RRP tax Exc
4. Ecost Exc (Actual Exc)
5. RRP tax Included
6. Ecost Tax Included (Actual Inc)
7. Replacement Prie
8. Quantity
9. Total Tax Excluded
10. Total Tax Included

We will need to change the column configuration to match the table so it is easy to hide the correct columns.
Comment 1 Lucas Gass 2020-05-21 23:47:04 UTC
Created attachment 105235 [details] [review]
Bug 25557: Correct basket.pl column config

This patch corrects the column configuration tool for basket.pl
TO TEST:
1. Go to Acquisitions and look at basket.pl
2. Open another tab and go to column configuration and try to hide some columns like Quantity.
3. See that the wrong columns are being hidden.
4. Apply patch
5. Trying hiding each column in the table and make sure the correct one is being hidden.
6. Rejoice!
Comment 2 Victor Grousset/tuxayo 2020-05-27 18:48:31 UTC
> 1. Go to Acquisitions and look at basket.pl

Is and individual basket? "Home › Acquisitions › My Vendor › Basket My Basket (1) for My Vendor "

Assuming yes.

> 2. Open another tab and go to column configuration and try to hide some columns like Quantity.
> 3. See that the wrong columns are being hidden.

Can't reproduce. I tried to hide and show most of the columns and nothing seemed wrong. (not sure if relevant, Quantity is hidden by default, no idea where the setting is)

What is the role of opening another tab?
Comment 3 Lucas Gass 2020-05-27 22:22:38 UTC
Victor,

Thanks for testing.

Are you attempting to hide/show the columns by using the column configuration tool? 

The only reason I said 'open a new tab' is so the tester can have the column configuration tool open in one tab and the table in another. To make it easier to test.
Comment 4 Victor Grousset/tuxayo 2020-05-28 03:50:30 UTC
(In reply to Lucas Gass from comment #3)
> Are you attempting to hide/show the columns by using the column
> configuration tool? 

Is that this thing? https://picat.drycat.fr/gallery#ZxsjxojK/D7urRk7F.png
Comment 5 Lucas Gass 2020-05-28 14:11:27 UTC
> Is that this thing? https://picat.drycat.fr/gallery#ZxsjxojK/D7urRk7F.png

Victor, 

No, I am referring to the Configure columns tool at Koha Admin > Configure columns.

/cgi-bin/koha/admin/columns_settings.pl

https://snipboard.io/Hk0N7V.jpg
Comment 6 Victor Grousset/tuxayo 2020-05-28 16:06:24 UTC
Created attachment 105421 [details] [review]
Bug 25557: Correct basket.pl column config

This patch corrects the column configuration tool for basket.pl
TO TEST:
1. Go to Acquisitions and look at basket.pl
2. Open another tab and go to column configuration and try to hide some columns like Quantity.
3. See that the wrong columns are being hidden.
4. Apply patch
5. Trying hiding each column in the table and make sure the correct one is being hidden.
6. Rejoice!

Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net>
Comment 7 Victor Grousset/tuxayo 2020-05-28 16:06:59 UTC
(In reply to Lucas Gass from comment #5)
> No, I am referring to the Configure columns tool at Koha Admin > Configure
> columns.
> 
> /cgi-bin/koha/admin/columns_settings.pl
> 
> https://snipboard.io/Hk0N7V.jpg

Hooooooo


> 3. See that the wrong columns are being hidden.

Indeed, nonsense can happen!


> 6. Rejoice!

It works! :D
Comment 8 Katrin Fischer 2020-05-28 21:32:59 UTC
Created attachment 105425 [details] [review]
k
Comment 9 Katrin Fischer 2020-05-28 21:33:43 UTC
Created attachment 105426 [details] [review]
Bug 25557: Correct basket.pl column config

This patch corrects the column configuration tool for basket.pl
TO TEST:
1. Go to Acquisitions and look at basket.pl
2. Open another tab and go to column configuration and try to hide some columns like Quantity.
3. See that the wrong columns are being hidden.
4. Apply patch
5. Trying hiding each column in the table and make sure the correct one is being hidden.
6. Rejoice!

Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Katrin Fischer 2020-06-11 13:08:04 UTC
*** Bug 25714 has been marked as a duplicate of this bug. ***
Comment 11 Jonathan Druart 2020-06-12 12:17:36 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 12 Lucas Gass 2020-06-16 22:21:04 UTC
backported to 20.05.x for 20.05.01
Comment 13 Aleisha Amohia 2020-06-17 00:16:38 UTC
backported to 19.11.x for 19.11.07
Comment 14 Victor Grousset/tuxayo 2020-06-18 15:37:46 UTC
Backported to 19.05.x branch for 19.05.12