Bug 25668 - ElasticSearch 6 deprecation: the default number of shards will change in version 7
Summary: ElasticSearch 6 deprecation: the default number of shards will change in vers...
Status: RESOLVED DUPLICATE of bug 27043
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 25439
  Show dependency treegraph
 
Reported: 2020-06-03 18:59 UTC by Victor Grousset/tuxayo
Modified: 2021-01-18 18:30 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Grousset/tuxayo 2020-06-03 18:59:26 UTC
This happens in koha-testing-docker with ES 6.8.8
When indexing:
./misc/search_tools/rebuild_elasticsearch.pl -v -d

Here are both deprecation messages that are outputted and related:

[DEPRECATION] the default number of shards will change from [5] to [1] in 7.0.0; if you wish to continue using the default of [5] shards, you must manage this on the create index request or with an index template - In request: {body => {settings => {index => {analysis => {analyzer => {analyzer_phrase => {char_filter => ["punctuation"],filter => ["icu_folding"],tokenizer => "keyword"},analyzer_standard => {filter => ["icu_folding"],tokenizer => "icu_tokenizer"},analyzer_stdno => {char_filter => ["punctuation"],filter => ["icu_folding"],tokenizer => "whitespace"}},char_filter => {punctuation => {pattern => "([\\x00-\\x1F,\\x21-\\x2F,\\x3A-\\x40,\\x5B-\\x60,\\x7B-\\x89,\\x8B,\\x8D,\\x8F,\\x90-\\x99,\\x9B,\\x9D,\\xA0-\\xBF,\\xD7,\\xF7])",replacement => "",type => "pattern_replace"}},normalizer => {icu_folding_normalizer => {filter => ["icu_folding"],type => "custom"},nfkc_cf_normalizer => {char_filter => "icu_normalizer",type => "custom"}}}},"index.mapping.total_fields.limit" => 10000}},ignore => [],method => "PUT",mime_type => "application/json",path => "/koha_kohadev_biblios",qs => {},serialize => "std"}


[DEPRECATION] the default number of shards will change from [5] to [1] in 7.0.0; if you wish to continue using the default of [5] shards, you must manage this on the create index request or with an index template - In request: {body => {settings => {index => {analysis => {analyzer => {analyzer_phrase => {char_filter => ["punctuation"],filter => ["icu_folding"],tokenizer => "keyword"},analyzer_standard => {filter => ["icu_folding"],tokenizer => "icu_tokenizer"},analyzer_stdno => {char_filter => ["punctuation"],filter => ["icu_folding"],tokenizer => "whitespace"}},char_filter => {punctuation => {pattern => "([\\x00-\\x1F,\\x21-\\x2F,\\x3A-\\x40,\\x5B-\\x60,\\x7B-\\x89,\\x8B,\\x8D,\\x8F,\\x90-\\x99,\\x9B,\\x9D,\\xA0-\\xBF,\\xD7,\\xF7])",replacement => "",type => "pattern_replace"}},normalizer => {icu_folding_normalizer => {filter => ["icu_folding"],type => "custom"},nfkc_cf_normalizer => {char_filter => "icu_normalizer",type => "custom"}}}},"index.mapping.total_fields.limit" => 10000}},ignore => [],method => "PUT",mime_type => "application/json",path => "/koha_kohadev_authorities",qs => {},serialize => "std"}
Comment 1 Victor Grousset/tuxayo 2021-01-18 18:30:06 UTC

*** This bug has been marked as a duplicate of bug 27043 ***