Bug 26382 - misc/maintenance/compare_es_to_db.pl is missing execution permission
Summary: misc/maintenance/compare_es_to_db.pl is missing execution permission
Status: RESOLVED DUPLICATE of bug 26384
Alias: None
Product: Koha
Classification: Unclassified
Component: Command-line Utilities (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Fridolin Somers
QA Contact: Testopia
URL:
Keywords:
Depends on: 22831
Blocks:
  Show dependency treegraph
 
Reported: 2020-09-04 08:24 UTC by Fridolin Somers
Modified: 2020-09-07 09:32 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 26382: fix misc/maintenance/compare_es_to_db.pl execution permission (740 bytes, patch)
2020-09-04 08:28 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 26382: fix misc/maintenance/compare_es_to_db.pl execution permission (797 bytes, patch)
2020-09-04 14:33 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin Somers 2020-09-04 08:24:43 UTC
Bug 22831 added script misc/maintenance/compare_es_to_db.pl without execution permission.
Comment 1 Fridolin Somers 2020-09-04 08:28:55 UTC
Created attachment 109648 [details] [review]
Bug 26382: fix misc/maintenance/compare_es_to_db.pl execution permission

Bug 22831 added script misc/maintenance/compare_es_to_db.pl without execution permission.

Test plan :
Apply patch and chech file misc/maintenance/compare_es_to_db.pl has
execution permission.
Comment 2 Fridolin Somers 2020-09-04 08:33:16 UTC
BTW there are a few other but maybe normal :

find -name '*.pl' -not -perm -755
./t/etc/schema.pl
./misc/load_testing/benchmark_staff.pl
./misc/maintenance/compare_es_to_db.pl
./kohaversion.pl
./cataloguing/value_builder/EXAMPLE.pl
Comment 3 Nick Clemens 2020-09-04 14:33:47 UTC
Created attachment 109665 [details] [review]
Bug 26382: fix misc/maintenance/compare_es_to_db.pl execution permission

Bug 22831 added script misc/maintenance/compare_es_to_db.pl without execution permission.

Test plan :
Apply patch and chech file misc/maintenance/compare_es_to_db.pl has
execution permission.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 4 Nick Clemens 2020-09-04 14:34:11 UTC
Trivial patch, passing QA

Thanks for the catch Frido!
Comment 5 Jonathan Druart 2020-09-07 09:32:33 UTC

*** This bug has been marked as a duplicate of bug 26384 ***