Bug 26389 - OPAC renewal failure due to automatic renewal does not have a failure message
Summary: OPAC renewal failure due to automatic renewal does not have a failure message
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Lucas Gass
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-04 13:50 UTC by Andrew Fuerste-Henry
Modified: 2020-11-17 20:42 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.06


Attachments
Bug 26389: Add auto renewal error to opac-user.tt (1.55 KB, patch)
2020-09-05 05:42 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 26389: Add auto renewal error to opac-user.tt (1.61 KB, patch)
2020-09-29 09:06 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 26389: Add auto renewal error to opac-user.tt (1.67 KB, patch)
2020-10-11 12:58 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2020-09-04 13:50:36 UTC
To recreate:
- Check out an auto-renewing item to a patron
- confirm in circ rules that the rule allows at least one renewal
- log into OPAC, confirm your summary shows item is scheduled for auto-renewal
- click Renew All
- Get note "Please note: Your loan renewal failed because of the following reason(s):" with no following reasons
Comment 1 Lucas Gass 2020-09-05 05:42:10 UTC
Created attachment 109685 [details] [review]
Bug 26389: Add auto renewal error to opac-user.tt

Test plan:
1 Check out an auto-renewing item to a patron
2 confirm in circ rules that the rule allows at least one renewal
3 log into OPAC, confirm your summary shows item is scheduled for auto-renewal
4 click Renew All
5 Get note "Please note: Your loan renewal failed because of the following reason(s):" with no following reasons
6 Apply patch
7 Repeat 3-5
8 See appropriate error
Comment 2 Fridolin Somers 2020-09-29 08:51:49 UTC
System preference OpacRenewalAllowed must be on "Allow"
Comment 3 Fridolin Somers 2020-09-29 09:05:35 UTC
(In reply to Lucas Gass from comment #1)
> Created attachment 109685 [details] [review] [review]
> Bug 26389: Add auto renewal error to opac-user.tt
> 
> Test plan:
> 1 Check out an auto-renewing item to a patron
> 2 confirm in circ rules that the rule allows at least one renewal
> 3 log into OPAC, confirm your summary shows item is scheduled for
> auto-renewal
> 4 click Renew All

I was able to display "Renew All" when item is in auto-renewal.

But one can run directly the URL to simulate it :
/cgi-bin/koha/opac-renew.pl?from=opac_user&item=<itemnumber>&borrowernumber=<borrowernumber>
Comment 4 Fridolin Somers 2020-09-29 09:06:29 UTC
Created attachment 110892 [details] [review]
Bug 26389: Add auto renewal error to opac-user.tt

Test plan:
1 Check out an auto-renewing item to a patron
2 confirm in circ rules that the rule allows at least one renewal
3 log into OPAC, confirm your summary shows item is scheduled for auto-renewal
4 click Renew All
5 Get note "Please note: Your loan renewal failed because of the following reason(s):" with no following reasons
6 Apply patch
7 Repeat 3-5
8 See appropriate error

Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com>
Comment 5 Katrin Fischer 2020-10-11 12:58:44 UTC
Created attachment 111459 [details] [review]
Bug 26389: Add auto renewal error to opac-user.tt

Test plan:
1 Check out an auto-renewing item to a patron
2 confirm in circ rules that the rule allows at least one renewal
3 log into OPAC, confirm your summary shows item is scheduled for auto-renewal
4 click Renew All
5 Get note "Please note: Your loan renewal failed because of the following reason(s):" with no following reasons
6 Apply patch
7 Repeat 3-5
8 See appropriate error

Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Jonathan Druart 2020-10-14 12:54:39 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 7 Lucas Gass 2020-11-13 14:19:55 UTC
backported to 20.05.x for 20.05.06
Comment 8 Aleisha Amohia 2020-11-17 03:59:20 UTC
I can't reproduce this in 19.11.x. Clicking Renew All doesn't do anything at all - no error. not backported