Bug 26496 - Budget plan save button doesn't save plans
Summary: Budget plan save button doesn't save plans
Status: Pushed to oldoldstable
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major with 5 votes (vote)
Assignee: David Cook
QA Contact: Katrin Fischer
URL:
Keywords:
: 22199 (view as bug list)
Depends on: 16754 20201
Blocks: 26754
  Show dependency treegraph
 
Reported: 2020-09-21 01:53 UTC by David Cook
Modified: 2020-11-17 10:28 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.06, 19.11.12, 19.05.17


Attachments
Bug 26496: Add op field to Budget Planning (1.39 KB, patch)
2020-09-21 02:06 UTC, David Cook
Details | Diff | Splinter Review
Bug 26496: Add op field to Budget Planning (1.58 KB, patch)
2020-09-24 23:35 UTC, David Cook
Details | Diff | Splinter Review
Bug 26496: Add op field to Budget Planning (1.65 KB, patch)
2020-10-19 19:41 UTC, ByWater Sandboxes
Details | Diff | Splinter Review
Bug 26496: Add op field to Budget Planning (1.70 KB, patch)
2020-10-20 13:48 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description David Cook 2020-09-21 01:53:12 UTC
Bug 16754 removed the "op" input from the Budget Plan (ie /cgi-bin/koha/admin/aqplan.pl), so clicking "Save" doesn't do anything anymore. 

I'm actually surprised that no one else has noticed this over the last 4 years...
Comment 1 David Cook 2020-09-21 01:54:13 UTC
It appears that Bug 20201 probably hid the warning for administrators at least...
Comment 2 David Cook 2020-09-21 01:54:43 UTC
Also worth noting that this is noted in 19.11. In master, the save button is gone all together... Bug 26495.
Comment 3 David Cook 2020-09-21 01:56:43 UTC
(In reply to David Cook from comment #2)
> Also worth noting that this is noted in 19.11. In master, the save button is
> gone all together... Bug 26495.

Ok actually it seems that the budget was locked, and that's why the save button was hidden. That's actually just suboptimal rather than a major problem...
Comment 4 David Cook 2020-09-21 02:06:41 UTC
Created attachment 110446 [details] [review]
Bug 26496: Add op field to Budget Planning

Without this patch, it's impossible to save a budget plan.

With this patch, it is possible to save a budget plan.

Test:
1. Apply patch
2. Go to a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgets.pl?budget_period_id=1)
3. Click "Planning" and "Plan by libraries"
4. Click "Auto-fill row" on the first line
5. Click "Save"
6. Note that results are saved and shown on the newly loaded page

To verify this patch is necessary, do the test plan without applying the patch.
Comment 5 David Cook 2020-09-21 02:07:02 UTC
This is a problem in master too
Comment 6 Rhonda Kuiper 2020-09-24 17:26:41 UTC
I tried to sign off using Bywater's sandboxes but noticed a couple things:
1) Under the 'Plan by....'  There are 6 strange 'Plan by...' with long strings of random characters.
2) The save button doesn't display so I am not able to save the plan.
I checked the Provision Log and the bug did apply.
I set this status to Failed QA to indicate the problem.  Is that correct when the sign off did work.
Also, bug 22199 is a duplicate of this bug.  I am not sure how to indicate that.
Comment 7 Katrin Fischer 2020-09-24 18:25:06 UTC
*** Bug 22199 has been marked as a duplicate of this bug. ***
Comment 8 Katrin Fischer 2020-09-24 18:26:28 UTC
(In reply to rkuiper from comment #6)
> I tried to sign off using Bywater's sandboxes but noticed a couple things:
> 1) Under the 'Plan by....'  There are 6 strange 'Plan by...' with long
> strings of random characters.
> 2) The save button doesn't display so I am not able to save the plan.
> I checked the Provision Log and the bug did apply.
> I set this status to Failed QA to indicate the problem.  Is that correct
> when the sign off did work.
> Also, bug 22199 is a duplicate of this bug.  I am not sure how to indicate
> that.

Hi,

1) Is not a real problem - it's only an issue with the sample data - nothing to worry about in a normal installation.

2) does sound like a real issue tho!

I've marked the other bug a duplicate. Usually we let the one with the lower bug number win, but in this case we have a patch here, so this bug wins :)

You can mark duplicates from the status pull down: Resolved duplicate + enter bug number in the field visible when this status is selected.
Comment 9 David Cook 2020-09-24 23:00:14 UTC
(In reply to Katrin Fischer from comment #8)
> (In reply to rkuiper from comment #6)
> > 2) The save button doesn't display so I am not able to save the plan.
> > I checked the Provision Log and the bug did apply.
> > I set this status to Failed QA to indicate the problem.  Is that correct
> > when the sign off did work.

> 2) does sound like a real issue tho!
> 

Oops, this is actually just an issue with my test plan not being descriptive enough. As I note in https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26496#c3, the Save button doesn't display if the budget is locked. I'll update the test plan...
Comment 10 David Cook 2020-09-24 23:35:20 UTC
Created attachment 110716 [details] [review]
Bug 26496: Add op field to Budget Planning

Without this patch, it's impossible to save a budget plan.

With this patch, it is possible to save a budget plan.

Test:
1. Apply patch
2. Modify a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgetperiods.pl?op=add_form&budget_period_id=1)
3. Unlock the budget if necessary by unticking "Lock budget" and click "Save"
4. Go to a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgets.pl?budget_period_id=1)
5. Click "Planning" and "Plan by libraries"
6. Click "Auto-fill row" on the first line
7. Click "Save"
8. Note that results are saved and shown on the newly loaded page

To verify this patch is necessary, do the test plan without applying the patch.
Comment 11 ByWater Sandboxes 2020-10-19 19:41:57 UTC
Created attachment 112011 [details] [review]
Bug 26496: Add op field to Budget Planning

Without this patch, it's impossible to save a budget plan.

With this patch, it is possible to save a budget plan.

Test:
1. Apply patch
2. Modify a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgetperiods.pl?op=add_form&budget_period_id=1)
3. Unlock the budget if necessary by unticking "Lock budget" and click "Save"
4. Go to a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgets.pl?budget_period_id=1)
5. Click "Planning" and "Plan by libraries"
6. Click "Auto-fill row" on the first line
7. Click "Save"
8. Note that results are saved and shown on the newly loaded page

To verify this patch is necessary, do the test plan without applying the patch.

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>
Comment 12 Barbara Johnson 2020-10-19 19:42:49 UTC
The test plan worked for me.
Comment 13 David Cook 2020-10-19 23:07:41 UTC
Cheers, Barbara!
Comment 14 Katrin Fischer 2020-10-20 13:48:47 UTC
Created attachment 112040 [details] [review]
Bug 26496: Add op field to Budget Planning

Without this patch, it's impossible to save a budget plan.

With this patch, it is possible to save a budget plan.

Test:
1. Apply patch
2. Modify a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgetperiods.pl?op=add_form&budget_period_id=1)
3. Unlock the budget if necessary by unticking "Lock budget" and click "Save"
4. Go to a budget (e.g. http://localhost:8081/cgi-bin/koha/admin/aqbudgets.pl?budget_period_id=1)
5. Click "Planning" and "Plan by libraries"
6. Click "Auto-fill row" on the first line
7. Click "Save"
8. Note that results are saved and shown on the newly loaded page

To verify this patch is necessary, do the test plan without applying the patch.

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 15 Jonathan Druart 2020-10-22 08:25:15 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 16 Lucas Gass 2020-11-13 16:06:20 UTC
backported to 20.05.x for 20.05.06
Comment 17 Aleisha Amohia 2020-11-17 04:10:59 UTC
backported to 19.11.x for 19.11.12
Comment 18 Victor Grousset/tuxayo 2020-11-17 10:28:23 UTC
Backported to 19.05.x branch for 19.05.17