Bug 26696 - Make payment table has a display issue when credits exist
Summary: Make payment table has a display issue when credits exist
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Katrin Fischer
QA Contact: Testopia
URL:
Keywords: Academy
Depends on:
Blocks:
 
Reported: 2020-10-15 17:29 UTC by Katrin Fischer
Modified: 2020-11-17 20:52 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.06


Attachments
Make payment tab in patron account in staff interface (51.59 KB, image/png)
2020-10-15 17:29 UTC, Katrin Fischer
Details
Bug 26696: Fix colspan in payment table when credit exists (1.88 KB, patch)
2020-10-15 23:30 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 26696: Fix colspan in payment table when credit exists (1.93 KB, patch)
2020-10-29 09:40 UTC, David Nind
Details | Diff | Splinter Review
Bug 26696: Fix colspan in payment table when credit exists (1.99 KB, patch)
2020-11-02 17:16 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2020-10-15 17:29:06 UTC
Created attachment 111775 [details]
Make payment tab in patron account in staff interface

The totals are off by one cell in the "make payment" tab on the staff side. See screenshot.
Comment 1 Katrin Fischer 2020-10-15 23:30:00 UTC
Created attachment 111818 [details] [review]
Bug 26696: Fix colspan in payment table when credit exists

The colspan was adjusted for the total due when a new column
was added to the table, but the 2 lines for credits were missed.

To test:
- Go to any patron account
- Create a manual invoice
- Create a credit
- Go to the 'Make a payment' tab
- Veriy that the total lines at the bottom of the table are
  slightly off
- Apply the patch
- Verify that the total lines in the table now display correctly
Comment 2 David Nind 2020-10-29 09:40:32 UTC
Created attachment 112661 [details] [review]
Bug 26696: Fix colspan in payment table when credit exists

The colspan was adjusted for the total due when a new column
was added to the table, but the 2 lines for credits were missed.

To test:
- Go to any patron account
- Create a manual invoice
- Create a credit
- Go to the 'Make a payment' tab
- Veriy that the total lines at the bottom of the table are
  slightly off
- Apply the patch
- Verify that the total lines in the table now display correctly

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 Martin Renvoize 2020-11-02 17:15:53 UTC
What's the attached image for Katrin?
Comment 4 Martin Renvoize 2020-11-02 17:16:57 UTC
Created attachment 112860 [details] [review]
Bug 26696: Fix colspan in payment table when credit exists

The colspan was adjusted for the total due when a new column
was added to the table, but the 2 lines for credits were missed.

To test:
- Go to any patron account
- Create a manual invoice
- Create a credit
- Go to the 'Make a payment' tab
- Veriy that the total lines at the bottom of the table are
  slightly off
- Apply the patch
- Verify that the total lines in the table now display correctly

Signed-off-by: David Nind <david@davidnind.com>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2020-11-02 17:17:18 UTC
Works as expected.. Passing QA
Comment 6 Katrin Fischer 2020-11-02 19:12:44 UTC
(In reply to Martin Renvoize from comment #3)
> What's the attached image for Katrin?

Oops, obviously not the right picture, but at least just a strange bugzilla screenshot!
Comment 7 Jonathan Druart 2020-11-03 09:59:00 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 8 Lucas Gass 2020-11-16 20:50:36 UTC
backported to 20.05.x for 20.05.06
Comment 9 Aleisha Amohia 2020-11-17 05:26:28 UTC
can't reproduce in 19.11.x, not backported