Bug 27022 - Add publisher number (MARC21 028) to OPAC and staff detail pages
Summary: Add publisher number (MARC21 028) to OPAC and staff detail pages
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic data support (show other bugs)
Version: 20.05
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Catherine
QA Contact: Marcel de Rooy
URL:
Keywords: Academy
Depends on:
Blocks:
 
Reported: 2020-11-13 19:44 UTC by Elaine Bradtke
Modified: 2021-06-14 21:35 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.03


Attachments
Bug 27022: Publisher number 028 does not display according to framework settings (5.38 KB, patch)
2021-01-21 02:39 UTC, Catherine
Details | Diff | Splinter Review
Bug 27022: Publisher number 028 does not display according to framework settings (5.38 KB, patch)
2021-01-21 02:43 UTC, Catherine
Details | Diff | Splinter Review
Bug 27022: Publisher number 028 does not display according to framework settings (5.44 KB, patch)
2021-01-21 20:10 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27022: Publisher number 028 does not display according to framework settings (5.54 KB, patch)
2021-01-22 09:14 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Elaine Bradtke 2020-11-13 19:44:30 UTC
The MARC 028 field is used to store the publisher number. This is a very important field for music libraries as both sound recordings and scores have publisher numbers that are used to track the version. 

The field does not display despite the fact that subfields are set to display in OPAC and staff interface in the relevant framework.
Comment 1 Katrin Fischer 2020-11-13 20:22:55 UTC
Hi Elaine, the visibility settings in the frameworks only affect the MARC views and they can hide fields that already are displayed in the XSLT files. 028 is not yet in the XSLT files, that's why I am resetting to enhancement - not a bug, but would be good to have.
Comment 2 Catherine 2021-01-21 02:39:58 UTC
Created attachment 115491 [details] [review]
Bug 27022: Publisher number 028 does not display according to framework settings

Test plan:
1. search the catalogue for an item
2. check if you can see the publisher number below the item title (you shouldn't)
3. click on the item and check if you can see the publisher number on
this page (you shouldn't)
4. in a new browser, repeat steps 1-3 on the OPAC
5. apply patch
6. repeat steps 1-4, however this time the publisher number SHOULD
display under the item titles

Sposored by Catalyst IT
Comment 3 Catherine 2021-01-21 02:43:12 UTC
Created attachment 115492 [details] [review]
Bug 27022: Publisher number 028 does not display according to framework settings

Test plan:
1. search the catalogue for an item
2. check if you can see the publisher number below the item title (you shouldn't)
3. click on the item and check if you can see the publisher number on
this page (you shouldn't)
4. in a new browser, repeat steps 1-3 on the OPAC
5. apply patch
6. repeat steps 1-4, however this time the publisher number SHOULD
display under the item titles

Sponsored by Catalyst IT
Comment 4 Katrin Fischer 2021-01-21 20:10:58 UTC
Created attachment 115617 [details] [review]
Bug 27022: Publisher number 028 does not display according to framework settings

Test plan:
1. search the catalogue for an item
2. check if you can see the publisher number below the item title (you shouldn't)
3. click on the item and check if you can see the publisher number on
this page (you shouldn't)
4. in a new browser, repeat steps 1-3 on the OPAC
5. apply patch
6. repeat steps 1-4, however this time the publisher number SHOULD
display under the item titles

Sponsored by Catalyst IT

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Katrin Fischer 2021-01-21 20:11:20 UTC
Nice clean and complete XSLT patch, thx Catherine!
Comment 6 Marcel de Rooy 2021-01-22 09:14:24 UTC
Created attachment 115669 [details] [review]
Bug 27022: Publisher number 028 does not display according to framework settings

Test plan:
1. search the catalogue for an item
2. check if you can see the publisher number below the item title (you shouldn't)
3. click on the item and check if you can see the publisher number on
this page (you shouldn't)
4. in a new browser, repeat steps 1-3 on the OPAC
5. apply patch
6. repeat steps 1-4, however this time the publisher number SHOULD
display under the item titles

Sponsored by Catalyst IT

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 7 Jonathan Druart 2021-01-22 13:54:07 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 8 Fridolin Somers 2021-01-29 13:44:36 UTC
Little enhancement, I choose to backport to stable.

Pushed to 20.11.x for 20.11.03
Comment 9 Andrew Fuerste-Henry 2021-02-04 21:13:12 UTC
Doesn't apply cleanly to 20.05. Please rebase if needed.
Comment 10 Elaine Bradtke 2021-03-04 17:27:52 UTC
Just a note of gratitude.  We are so impressed with how swiftly this item was addressed.  It's a really important field for us.  A big thank you to everyone who worked on it.